-   Linux - Software (
-   -   xine gui install doesn't find xine-lib (

blackdragonblood 02-10-2006 02:01 PM

xine gui install doesn't find xine-lib
I'm trying to install a zine gui after compiling the xine-lib. When I run ./configure for the gui, I get the following.

*** Could not run XINE test program, checking why...
*** The test program compiled, but did not run. This usually means
*** that the run-time linker is not finding XINE or finding the wrong
*** version of XINE. If it is not finding XINE, you'll need to set your
*** LD_LIBRARY_PATH environment variable, or edit /etc/ to point
*** to the installed location Also, make sure you have run ldconfig if that
*** is required on your system
*** If you have an old version installed, it is best to remove it, although
*** you may also be able to get things to work by modifying LD_LIBRARY_PATH
configure: error: *** You should install xine-lib first ***
Any ideas?

blackdragonblood 02-10-2006 02:51 PM

ok, I got around the above my typing what it asks me to. Now I get this from ./configure


configure: error: *** libpng is needed (PNG library not found) - try to use --with-png-prefix option ***
Where is libpng? Do I need to install it?

Boow 02-10-2006 03:23 PM

what distro are you using why not just use rpms instead of trying to compile.

blackdragonblood 02-10-2006 03:33 PM

I'm using Fedora Core 4. I tried the rpms but I get dependency failures. I thought it I would have better luck compiling from source. I should have mentioned it eariler. Here is what I get from rpm.


warning: xine-lib-1.1.1-1.2.fc4.i386.rpm: Header V3 DSA signature: NOKEY, key ID e42d547b
error: Failed dependencies: is needed by xine-lib-1.1.1-1.2.fc4.i386 is needed by xine-lib-1.1.1-1.2.fc4.i386
libdvdcss is needed by xine-lib-1.1.1-1.2.fc4.i386 is needed by xine-lib-1.1.1-1.2.fc4.i386
How do I go about solving these dependencies? Should I still compile from source?

jlo_sandog 02-10-2006 04:19 PM

While you're there download mplayer rpms. If you choose mplayer you have to install the win32 codecs before the mplayer files.

you can set up yum to do the install from freshrpms just read on the website for details.

blackdragonblood 02-10-2006 06:19 PM

That did the trick. Thx.

All times are GMT -5. The time now is 08:47 PM.