LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-03-2004, 04:49 PM   #1
GiZiM
LQ Newbie
 
Registered: Aug 2004
Posts: 18

Rep: Reputation: 0
Xine does not like some WMV files


Some of the WMV files Xine tries to play just crash out Xine and i dont know why. I already have the W32 Codecs installed any ideas? if i open from the term. so i can see the crash message its this

[gizim@localhost gizim]$ xine
This is xine (X11 gui) - a free video player v0.99.2.
(c) 2000-2004 The xine Team.
Segmentation fault
[gizim@localhost gizim]$
 
Old 09-03-2004, 06:23 PM   #2
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 85
Welcome to LQ! Have you verified that the files that cannot be played are intact and not corrupted in some way? Clearly if the file suffered some kind of corruption or data loss during the download, it won't be playable. That's just a possibility, but I think it's good practice to always check the inputs to a program before concluding that the outputs are bad.

That being said, the fact that some files are playable is a good sign. -- J.W.
 
Old 09-03-2004, 08:00 PM   #3
GiZiM
LQ Newbie
 
Registered: Aug 2004
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by J.W.
Welcome to LQ! Have you verified that the files that cannot be played are intact and not corrupted in some way? Clearly if the file suffered some kind of corruption or data loss during the download, it won't be playable. That's just a possibility, but I think it's good practice to always check the inputs to a program before concluding that the outputs are bad.

That being said, the fact that some files are playable is a good sign. -- J.W.
Thanks yeah they are fine they are on a different H/D than my linux install.
They worked fine on Windows XP
 
Old 09-03-2004, 11:52 PM   #4
salahuddin_66
Member
 
Registered: Jan 2004
Location: Dhaka, Bangladesh
Distribution: Debian, Gentoo
Posts: 283

Rep: Reputation: 30
delete the .xine folder from u r home directory

otherwise

better install http://www.mplayerhq.hu/ & download the win32 codecs

i ahve install mplayer and my win32 dir is /usr/local/lib/win32

better try to install the mplayer from source

give ./configure --help

and tell is the lame (u have to download lame from sf.net )
and xvid codecs optional

and the win32 dir

i think it will help u
 
Old 09-03-2004, 11:59 PM   #5
crane
Member
 
Registered: Sep 2003
Location: Alabama
Distribution: Blag, Fedora core 1 and 2, Clarck Connect
Posts: 70

Rep: Reputation: 15
yum install mplayer
 
Old 09-04-2004, 12:57 AM   #6
GiZiM
LQ Newbie
 
Registered: Aug 2004
Posts: 18

Original Poster
Rep: Reputation: 0
ok i did not get most that post but thank you i have Mplayer installed and like i said i already got the W32 Codecs installed from Synaptic and when i try and use mplayer it does NOT open a WMV file at all. It doesnt even try.
 
Old 09-04-2004, 01:10 AM   #7
GiZiM
LQ Newbie
 
Registered: Aug 2004
Posts: 18

Original Poster
Rep: Reputation: 0
I went to MPlayers site and downloaded some other codecs where do i install them?? how do i recompile them?
 
Old 09-04-2004, 01:13 AM   #8
salahuddin_66
Member
 
Registered: Jan 2004
Location: Dhaka, Bangladesh
Distribution: Debian, Gentoo
Posts: 283

Rep: Reputation: 30
hmm

open a shell

run gmplayer from shell

then try to open a WMV file and see where the mplayer search for the win32 dir

if it is wrong place then move it where the mplayer search

or may be the mplayer was not compile with the win32 codecs support

after compile mplayer (i ahve compile with win32libdir=/usr/local/lib/codecs
but i can't open wmv files then i try in shell and found that my mplayer searching codecs in /usr/local/lib/win32 (becoz it is pre5)

after copy dlls in /usr/local/lib/win32 then i can play all wmv files
 
Old 09-04-2004, 01:14 AM   #9
rm6990
Member
 
Registered: Aug 2004
Location: Canada
Distribution: SUSE 9.1 Pro and Debian Testing on Server
Posts: 469

Rep: Reputation: 30
Go to Linux.com and on there on the first pae there should be an article about how to play DVD's on any Linux Distro, it also touches a bit on WM files. Maybe go and check it out.
 
Old 09-04-2004, 01:16 AM   #10
GiZiM
LQ Newbie
 
Registered: Aug 2004
Posts: 18

Original Poster
Rep: Reputation: 0
CPU: Advanced Micro Devices Athlon Thunderbird 1395 MHz (Family: 6, Stepping: 4)Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Reading config file /etc/mplayer/mplayer.conf: No such file or directory
Reading config file /home/gizim/.mplayer/config
[cfg] read config file: /home/gizim/.mplayer/gui.conf
Reading config file /home/gizim/.mplayer/gui.conf
vo: X11 running at 1280x1024 with depth 24 and 32 bpp (":0.0" => local display)
xscreensaver_disable: xscreensaver wid=10485768.
Reading /home/gizim/.mplayer/codecs.conf: Can't open '/home/gizim/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: Can't open '/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
font: can't open file: /home/gizim/.mplayer/font/font.desc
Font /usr/share/mplayer/font/font.desc loaded successfully! (206 chars)
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Using usleep() timing
Can't open input config file /home/gizim/.mplayer/input.conf: No such file or directory
Can't open input config file /etc/mplayer/input.conf: No such file or directory
Falling back on default (hardcoded) input config
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such device
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support.
You will not be able to use your remote control.
SKIN dir 1: '/home/gizim/.mplayer/Skin'
SKIN dir 2: '/usr/share/mplayer/Skin'

then

Playing /home/gizim/Downloads/Bayfront sat.wmv.
ASF file format detected.
VIDEO: [WMV3] 320x240 24bpp
Clip info:
name:
author:
copyright:
comments:
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 8005->176400 (64.0 kbit)
Selected audio codec: [ffwmav2] afm:ffmpeg (DivX audio v2 (ffmpeg))
==========================================================================
==========================================================================
Trying to force video codec driver family vfw...
Opening video decoder: [dmo] DMO video codecs

Last edited by GiZiM; 09-04-2004 at 01:18 AM.
 
Old 09-04-2004, 01:19 AM   #11
GiZiM
LQ Newbie
 
Registered: Aug 2004
Posts: 18

Original Poster
Rep: Reputation: 0
The mplayer.conf files are not even there!
WTF! this was installed with RedHat RPM so now what do i do?
download the source and compile it with the W32 Codes?
Where do i install mplayer to?
 
Old 09-04-2004, 03:02 AM   #12
salahuddin_66
Member
 
Registered: Jan 2004
Location: Dhaka, Bangladesh
Distribution: Debian, Gentoo
Posts: 283

Rep: Reputation: 30
heres mine

Code:
salahuddin@localhost:~$ gmplayer
MPlayer 1.0pre5-3.3.4 (C) 2000-2004 MPlayer Team

CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville 748.1 MHz (Family: 6, Stepping: 6)
Detected cache-line size is 32 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled with runtime CPU detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.
Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /home/salahuddin/.mplayer/config
[cfg] read config file: /home/salahuddin/.mplayer/gui.conf
Reading config file /home/salahuddin/.mplayer/gui.conf
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
Reading /home/salahuddin/.mplayer/codecs.conf: Can't open '/home/salahuddin/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: Can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
font: can't open file: /home/salahuddin/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Using usleep() timing
Can't open input config file /home/salahuddin/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or directory
Falling back on default (hardcoded) input config
SKIN dir 1: '/home/salahuddin/.mplayer/Skin'
SKIN dir 2: '/usr/local/share/mplayer/Skin'
Selected font is fixed-width.
Selected font is fixed-width.

Playing /home/salahuddin/song/video/hindi/Thodasa pagla.wmv.
ASF file format detected.
VIDEO:  [WMV3]  320x240  24bpp
Clip info:
 comments:
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 6003->176400 (48.0 kbit)
Selected audio codec: [ffwmav2] afm:ffmpeg (DivX audio v2 (ffmpeg))
==========================================================================
==========================================================================
Opening video decoder: [dmo] DMO video codecs
External func OLEAUT32.dll:8
DMO dll supports VO Optimizations 0 1
DMO dll might use previous sample when requested
GetOutput r=0x0   size:230400  align:1
StreamCount r=0x0  1  1
Decoder supports the following YUV formats: YV12 YUY2 UYVY YVYU   ▒
Decoder is capable of YUV output (flags 0x1b)
VDec: vo config request - 320 x 240 (preferred csp: Packed YUY2)
VDec: using BGR 24-bit as output csp (no 4)
Movie-Aspect is undefined - no prescaling applied.
VO: [gl2] 320x240 => 320x240 BGR 24-bit
[gl2] You have OpenGL >= 1.2 capable drivers, GOOD (16bpp and BGR is ok!)
[gl2] antialiasing off
[gl2] bilinear linear
Selected video codec: [wmv9dmo] vfm:dmo (Windows Media Video 9 DMO)
==========================================================================
Checking audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 44100 hz, little endian signed int
AF_pre: 44100Hz 2ch Signed 16-bit (Little-Endian)
AO: [arts] Connected to sound server
AO: [arts] Stream opened
AO: [arts] buffer size: 20480
AO: [arts] packet size: 2048
AO: [arts] 44100Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
Starting playback...
Selected font is fixed-width.
A:  21.9 V:  21.8 A-V:  0.047 ct: -0.008  452/452  21% 19%  3.5% 5 0 0%
  =====  PAUSE  =====

frist try to remove the .mplayer folder

and try again

if fail then try to install from source

but install from source is not easy (with all support)
 
Old 09-04-2004, 03:10 AM   #13
salahuddin_66
Member
 
Registered: Jan 2004
Location: Dhaka, Bangladesh
Distribution: Debian, Gentoo
Posts: 283

Rep: Reputation: 30
install from source

frist remove the installed mplayer

frist download the lame from sf.net (search in sf.net)

./compile
make
make install

then it will install default in /usr/local/lib
and install the divx and Xvid from www.divx.com and www.xvid.org (optional)
download all the win32 codec from www.mplayerhq.hu and the source pre5 latest i am using

make a folder in /usr/local/lib/win32 and copy the dll's in this folder


ldconfig command as root

then

./configure --help


heres mine
----------------------------------------------------------------------
./configure --enable-gui --enable-mencoder --enable-largefiles --enable-ftp --disable-gif --enable-png --enable-jpeg --enable-win32 --enable-dshow --enable-real --enable-xvid --enable-divx4linux --enable-libavcodec --enable-vorbis --enable-mp3lib --enable-libmpeg2 --enable-vidix --enable-gl --enable-vesa --enable-mga --enable-xv --enable-xmga --enable-x11 --enable-directfb --enable-alsa --enable-ossaudio --enable-arts --enable-esd --enable-runtime-cpudetection --enable-i18n --with-win32libdir=/usr/local/lib/codecs --with-xvidlibdir=/usr/local/lib/libxvidcore.a --with-xvidincdir=/usr/local/include/ --with-codecsdir=/usr/local/lib/


make

make install




BYE
 
Old 09-04-2004, 03:13 AM   #14
salahuddin_66
Member
 
Registered: Jan 2004
Location: Dhaka, Bangladesh
Distribution: Debian, Gentoo
Posts: 283

Rep: Reputation: 30
try to remove --enable-runtime-cpudetection from ./configure
 
Old 09-04-2004, 12:13 PM   #15
GiZiM
LQ Newbie
 
Registered: Aug 2004
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by salahuddin_66
install from source

frist remove the installed mplayer

frist download the lame from sf.net (search in sf.net)

./compile
make
make install

then it will install default in /usr/local/lib
and install the divx and Xvid from www.divx.com and www.xvid.org (optional)
download all the win32 codec from www.mplayerhq.hu and the source pre5 latest i am using

make a folder in /usr/local/lib/win32 and copy the dll's in this folder


ldconfig command as root

then

./configure --help


heres mine
----------------------------------------------------------------------
./configure --enable-gui --enable-mencoder --enable-largefiles --enable-ftp --disable-gif --enable-png --enable-jpeg --enable-win32 --enable-dshow --enable-real --enable-xvid --enable-divx4linux --enable-libavcodec --enable-vorbis --enable-mp3lib --enable-libmpeg2 --enable-vidix --enable-gl --enable-vesa --enable-mga --enable-xv --enable-xmga --enable-x11 --enable-directfb --enable-alsa --enable-ossaudio --enable-arts --enable-esd --enable-runtime-cpudetection --enable-i18n --with-win32libdir=/usr/local/lib/codecs --with-xvidlibdir=/usr/local/lib/libxvidcore.a --with-xvidincdir=/usr/local/include/ --with-codecsdir=/usr/local/lib/


make

make install




BYE
Ok one small question i can not find anything for linux on www.divx.com
and install the divx and Xvid from www.divx.com where is it for linux?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Playing WMV files with MPlayer or Xine dth1 Linux - Software 7 08-16-2005 06:18 AM
Problem with playing wmv files on Slackware 10 using xine laiboonh Slackware 1 11-03-2004 01:01 AM
Cant Play wmv files on mplayer or xine irish rebel Linux - Software 1 10-22-2004 11:32 PM
playing avi and wmv files in xine ? BajaNick Linux - Software 21 08-29-2004 03:34 PM
xine plays only (a part of) the sound of a wmv, some divx files and crushes mp4 files bezoomny Linux - Software 1 03-10-2004 08:33 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration