LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-19-2005, 02:08 PM   #1
Trickj
LQ Newbie
 
Registered: Apr 2005
Location: Helsinki, Finland, Europe
Distribution: Ubuntu 6.06 LTS - Dapper Drake
Posts: 8

Rep: Reputation: 0
Xine distorting sound and dropping frames when playing .avi-movies


I've been trying to watch video clips I've recorded on my Canon A95, but when I open them in Xine the sound output is distorted and contains a lot of screeching sounds, while the video drops frames like no tomorrow.

What could be wrong? AVIs used to work and then this problem suddenly appeared. At first I thought the camera's mic was borked, but it doesn't appear to be broken since the camera can play them fine. It's probably not caused by me changing sound cards either since this problem started before that (sound hardware used to be an integrated realtek chip).

Using Xine 0.99.4, with mplayer codec pack (all) on a computer containing an ATI Radeon 9800 Pro (using 8.16.20 drivers) and a Soundblaster Audigy 2 Value (using snd-emu10k1 module and alsa 1.0.9 -1.2) on Fedora Core 4.
 
Old 11-19-2005, 05:10 PM   #2
jlo_sandog
Member
 
Registered: Jul 2005
Location: USA
Distribution: F10 (x86_64)
Posts: 549

Rep: Reputation: 32
from the website (below)
http://cambuca.ldhs.cetuc.puc-rio.br/xine/

Make sure the DMA is enabled for your DVD-ROM, otherwise playback will be 'jumpy'.
# hdparm -d1 /dev/cdrom
 
Old 11-21-2005, 03:04 AM   #3
Trickj
LQ Newbie
 
Registered: Apr 2005
Location: Helsinki, Finland, Europe
Distribution: Ubuntu 6.06 LTS - Dapper Drake
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by jlo_sandog
from the website (below)
http://cambuca.ldhs.cetuc.puc-rio.br/xine/

Make sure the DMA is enabled for your DVD-ROM, otherwise playback will be 'jumpy'.
# hdparm -d1 /dev/cdrom
I guess I should have specified that the movies I'm trying to watch are on the HDD.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Xine playing frames out of order JohnCain Linux - Software 2 05-10-2005 02:12 AM
DVD Programs Dropping Frames... sxa Linux - Software 7 12-23-2004 04:20 PM
playing avi and wmv files in xine ? BajaNick Linux - Software 21 08-29-2004 03:34 PM
no sound when playing avi + wmv's FLOODS Linux - Software 6 05-18-2004 02:22 PM
Problem with sound while playing movies JIV Linux - Newbie 3 02-25-2003 05:53 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration