LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Xine crash when trying to play H.264 movies. (https://www.linuxquestions.org/questions/linux-software-2/xine-crash-when-trying-to-play-h-264-movies-748453/)

masmddr 08-18-2009 11:03 AM

Xine crash when trying to play H.264 movies.
 
Hello.

I've tried watching a movie encoded with H.264 codec but Xine/GXine crash when I try to do so due to "Floating point exception".
trying to play it with Noatun crashes the sound server.

Some info about the movie from MediaInfo:

Quote:

Format : MPEG-4
Format/Info : ISO 14496-1 Base Media
Format/Family : MPEG-4
File size : 1.39 GiB
PlayTime : 1h 50mn
Bit rate : 1809 Kbps
StreamSize : 1.82 MiB
Encoded date : UTC 2009-08-10 14:43:03
Tagged date : UTC 2009-08-10 14:43:03

Video #0
Codec : H.264
Codec/Info : H.264 (3GPP)
PlayTime : 1h 49mn
Bit rate : 1650 Kbps
Width : 704 pixels
Height : 288 pixels
Aspect ratio : 2.444
Frame rate : 25.000 fps
StreamSize : 1.27 GiB
Encoded date : UTC 2009-08-07 13:32:08
Tagged date : UTC 2009-08-10 14:44:00

Audio #0
Codec : ac-3
PlayTime : 1h 50mn
Bit rate : 160 Kbps
Channel(s) : 2 channels
Sampling rate : 48 KHz
Resolution : 16 bits
StreamSize : 126 MiB
Encoded date : UTC 2009-08-10 14:43:44
Tagged date : UTC 2009-08-10 14:44:00
I Have no problem playing other movies who use AC3 for audio so I'm guessing it's the video.
any ideas?

using Slackware 12.2

GrapefruiTgirl 08-18-2009 11:09 AM

So, in both cases, is the Error coming from the Sound Server or other Sound item? Or is it perhaps caused by a Video driver?

If you use the nVidia video driver, check the ChangeLog(s) for the most recent drivers, as there are frequent and plentiful bug-fixes related to h.264 and other video formats.

Providing more info with your question could help answer it; such as hardware involved, video/audio devices, etc., as well as the actual error message if it differs from what you posted.

Sasha

masmddr 08-18-2009 11:40 AM

In Xine/GXine case they crash with no errors, if I run them from the console I see "Floating point exception".
Noatun invokes the KDE crash handler saying that the sound server (artsd) have crashed.

I am using a GigaByte w536m Laptop with:
Chipset : Mobile Intel® Express Chipset GM965 + ICH8M
VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller
Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller
the VGA card in xorg.conf:

Code:

Section "Device"
    Identifier        "GM965"
    Driver        "intel"
    BusID        "PCI:0:2:0"

EndSection



All times are GMT -5. The time now is 09:42 PM.