LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-15-2004, 07:46 AM   #1
vovanus
LQ Newbie
 
Registered: Aug 2004
Posts: 5

Rep: Reputation: 0
Xfree86 With 14" Display


Hi guys!
I've got a huge problem - it is essential for me as I am just starting to learn Linux. Let's start with my configuration. It's AMD Athlon XP 1700+, Video card is S3 Savage Km 133 and... a 14" display - I really like it and I don't want to change it. The display is Belinea 10 40 45 and it works good under Windows at even 1024x768, though I usually use 800x600. I am trying to set up 800x600 for Linux, but I always fail to start X server with these parameters. The image on display runs down... and it is impossible to view anything. When I set up 640x480, everything is OK, but... add my 14" display - everything is so big and it is impossible to work too. Let me include my XF86Config file

# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "max4045"
HorizSync 30.0 - 50.0
VertRefresh 50.0 - 120.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "savage"
VendorName "Videocard vendor"
BoardName "S3 ProSavage KM133"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 16
Modes "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

When I am tring to change this to 800*600 I am getting the described above... I've checked my display parameters - they're ok... Any help is appreciated
 
Old 08-15-2004, 08:49 AM   #2
BigNate
Member
 
Registered: Mar 2003
Location: Harrisburg, PA
Distribution: Gentoo, Debian, Ubuntu, Red Hat/CentOS
Posts: 719

Rep: Reputation: 30
well, I am no Xfree guru, so take my advice at your own risk

But the "VertRefresh 50.0 - 120.0" seems a little high. If you have the actual refresh rates you could try tweaking those manually in the config. Or, run 'xf86config' from the command line and be prepared to answer the questions about your video card, mouse, keyboard and monitor. That might help. It seems that the redhat generated XF86Config is not correct as it would work if it was
 
Old 08-15-2004, 09:02 AM   #3
vovanus
LQ Newbie
 
Registered: Aug 2004
Posts: 5

Original Poster
Rep: Reputation: 0
I've tried to modify refresh rate VertRefresh - it doesn't help This is writter in my disp[lay specification... and it works for 640x480... is there any dependence of the resolution and refresh rate?
 
Old 08-15-2004, 09:16 AM   #4
BigNate
Member
 
Registered: Mar 2003
Location: Harrisburg, PA
Distribution: Gentoo, Debian, Ubuntu, Red Hat/CentOS
Posts: 719

Rep: Reputation: 30
Are you saying this is the actual vert refreash rate?
 
Old 08-15-2004, 09:37 AM   #5
vovanus
LQ Newbie
 
Registered: Aug 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Yes, this is the current setting. 50-120 and X server does not start if I change this to smaller values.
 
Old 08-15-2004, 01:12 PM   #6
binidiot
Member
 
Registered: May 2004
Location: Spain
Distribution: Debian Woody, FreeBSD 5.2.1
Posts: 106

Rep: Reputation: 15
Maybe I am confused, but your config file only shows 640 by 480 mode. Have you tried adding the 800 by 600 mode to the config??
 
Old 08-15-2004, 02:10 PM   #7
vovanus
LQ Newbie
 
Registered: Aug 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Yes, certainly, I've tried to do that, but this way it does not work... that's why I am asking for the solution. If anyone knows who I may contact in regards with this question (forums, etc). this will be greatly appreciated.
 
Old 08-15-2004, 02:12 PM   #8
BigNate
Member
 
Registered: Mar 2003
Location: Harrisburg, PA
Distribution: Gentoo, Debian, Ubuntu, Red Hat/CentOS
Posts: 719

Rep: Reputation: 30
Quote:
Originally posted by binidiot
Maybe I am confused, but your config file only shows 640 by 480 mode. Have you tried adding the 800 by 600 mode to the config??
Good catch...here is a sample from my config:

Code:
 Subsection "Display"
        Depth       8
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
Play around with that.
 
Old 08-15-2004, 03:02 PM   #9
vovanus
LQ Newbie
 
Registered: Aug 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Tried... this didn't help too. Maybe anyone had a 14" with Linux installed... as My display will not handle 1280x1024 etc.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
"Xlib: extension "XFree86-DRI" missing on display ":0.0"." zaps Linux - Games 9 05-14-2007 03:07 PM
how to solve missing "XFree86-DRI" on display ":0.0" digitX Linux - Software 13 03-05-2005 03:46 AM
Xlib: extension "XFree86-DRI" missing on display ":0.0". fostiator Linux - Hardware 15 02-20-2005 07:13 AM
"extension "XFree86-DRI" missing on display" upgrading XFree86 to 4.3.0 on Sarge Moloko Debian 5 03-31-2004 05:06 PM
bash-2.05b# Xlib: extension "XFree86-DRI" missing on display ":0.0". citrus Linux - General 8 02-22-2004 10:43 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration