LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-29-2014, 09:01 AM   #1
tuto
LQ Newbie
 
Registered: Aug 2013
Posts: 11

Rep: Reputation: Disabled
Angry Xfce-terminal misbihaves with non-ASCI characters


I just installed Xfce4 and start using its default terminal. Terminal's default character encoding is set to UTF-8. I'm bulgarian so sometimes I work with cyrillic text. Cyrillic characters are rendered, but it's like xfce-terminal is confused by them.

Click image for larger version

Name:	xfce-terminal-misbihaving.png
Views:	172
Size:	38.4 KB
ID:	15628

The first line shows these bulgarian letters "фйфоъсжкфт". Of course this is only example, I don't have script with that name. Letters overlap. This is incorrect!
The second line shows what happens when I hit Enter .
The third line shows what happens when I keep pressing Backspace key. Part of the prompt is erased.
In the last line I pressed "up" once to envoke shell history. Question marks suddenly appeared.
 
Old 05-29-2014, 09:47 AM   #2
tuto
LQ Newbie
 
Registered: Aug 2013
Posts: 11

Original Poster
Rep: Reputation: Disabled
Setting locale

Ok, I changed my locale from "C" to "bg_BG.UTF8" and most of the problems were solved (see this article locale). Letters, however, still overlap!
 
Old 05-29-2014, 10:33 AM   #3
DavidMcCann
LQ Veteran
 
Registered: Jul 2006
Location: London
Distribution: PCLinuxOS, Salix
Posts: 6,158

Rep: Reputation: 2318Reputation: 2318Reputation: 2318Reputation: 2318Reputation: 2318Reputation: 2318Reputation: 2318Reputation: 2318Reputation: 2318Reputation: 2318Reputation: 2318
I've just checked at the Xfce forum, and no-one has reported this problem, although there some people having other problems with Cyrillic fonts. It might just be that the default font doesn't display properly: try configuring the terminal program to use a different one.
 
Old 05-29-2014, 11:49 AM   #4
tuto
LQ Newbie
 
Registered: Aug 2013
Posts: 11

Original Poster
Rep: Reputation: Disabled
I solved the problem by using different font.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Inputting accented characters under xfce wizardhat Slackware 6 03-19-2009 03:30 PM
Unusual characters in X terminal apex.predator Slackware 15 07-22-2008 01:24 PM
how do i write a asci-char withthe number? kalleanka Programming 11 04-28-2008 12:53 PM
Terminal and gnome-terminal crashing X in Xfce Warren Watts Arch 3 12-12-2007 11:33 PM
Weird Characters in terminal Mr. New Linux - Newbie 3 05-10-2005 04:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration