LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   xf4vnc, xorg.conf and authentication (https://www.linuxquestions.org/questions/linux-software-2/xf4vnc-xorg-conf-and-authentication-475742/)

cygnus-x1 08-20-2006 09:44 PM

xf4vnc, xorg.conf and authentication
 
I just installed xf4vnc on a CentOS machine. The install scripts for xf4vnc would not work as it was looking for XF86Config. So I nrenamed my xorg.conf file to XF86Config and ran th einstall. I then renamed the file back to xorg.conf. I also have the CentOS system set to boot to run level 3 (not 5). So here are my questions / problems.

1) Since xf4vnc gets started when a user logs in and runs startx, does it matter what/who that user is? I assume it would not.

2) By default xf4vnc does not require authentication. However I am met with a password prompt when I try to use it. I do not have any auth settings set in xorg.conf ... any ideas?

3) I then tried to add authentication but that did not work either. Is there something special I have to do because its I have an xorg.conf vs an XF86Config ??

I grabbed the latest xf4vnc from the doewnload site

thanks in advance

Doug

cygnus-x1 08-21-2006 01:15 PM

I poked around a little further and in a somewhat related post about Xvnx with xorg I saw a link that described hooking xorg up with Xvnc. There was an option called SecurityTypes that the xf486 install script did not add to the xorg.conf so I said what the heck ... it can't hurt nuthin. Well that was the magic key that worked.


Section "Screen"
...
Option "SecurityTypes" "None"
EndSection

This solved my dilemna. I also verified that if you boot into run level 3 it does not matter if its root or a normal user that starts X.


All times are GMT -5. The time now is 02:38 AM.