-   Linux - Software (
-   -   XEmacs -- GTK? (

trashbird1240 12-04-2006 11:16 AM

XEmacs -- GTK?
Howdy Y'all,

I'm running Slackware 11.0 with Enlightenment DR17 (on that front I think KDE and Gnome have competition). I did "slocate gtk" and found I have numerous gtk libraries on this installation, even though I chose not to install Gnome or KDE.

I use XEmacs (all the time) and I noticed in the INSTALL file that I can pass options to configure to tell it which X toolkit I want for the scrollbars, dialogs and widgets. Currently I have the default widgets, etc., because I passed no options to ./configure when I installed.

This morning I redid ./configure after running

make clean
make distclean

in the original source tree (/usr/src).

I ran

./configure --with-scrollbars=gtk --with-dialogs=gtk --with-widgets=gtk

and configure ran smoothly. When I ran


I got errors saying pointers to athena were invalid.

This raises several questions:
Is this feature active? In other words, I'd think the ./configure options would replace pointers to athena with pointers to gtk.

Do I have everything I need to compile with gtk widgets? (how do I find out what I do have?)

Is it really going to look different? (the athena/lucid widgets look archaic) I saw a screenshot of GNU Emacs in "Learning GNU Emacs" from O'Reilly that looked really modern, like other GTK applications.

How do I uninstall properly so that I can replace the current installation, in the event that I recompile with different options?

(If you're wondering, no I don't use XEmacs for C programming ;) I don't use anything for C programming)


solnul 12-17-2006 08:10 AM

Could you post more info and exact messages?

When you ran configure it should have given you lots of output about exactly what it found where, e.g.

checking gtk version... 1.2.10
checking gtk libs... -L/usr/lib64 -L/usr/lib64 -lgtk -lgdk -rdynamic -lgmodule -lglib -ldl -lXi -lXext -lX11 -lm

It's possible it didn't find the right GTK stuff and fell back on Athena.

Also note that XEmacs (unlike FSF Emacs) only supports the older GTK+ 1.2. So if you only have the newer and incompatible GTK+ 2.0 it won't compile.
Themes, etc are also separate from GTK2 apps.

trashbird1240 12-22-2006 09:28 AM


I've done this again a couple times. The thing is to use


in addition to the scrollbars, etc., options.

Now, the thing is that some of my custom options are failing to come through.

For example, despite setting the following:

(setq initial-frame-plist '(height 50 width 100))

the frame always comes up as a quarter of the screen. Also, I usually set

'(toolbar ((t (:foreground "grey" :background "black"))) t)

in custom.el, I still get the toolbar. Before I only got the toolbar when I loaded particular extensions (e.g., AUCTEX).

Any thoughts?

All times are GMT -5. The time now is 08:07 PM.