LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   XChat / GTK+2.0 / GLib problems :( (https://www.linuxquestions.org/questions/linux-software-2/xchat-gtk-2-0-glib-problems-77652/)

goosh 07-31-2003 10:16 AM

XChat / GTK+2.0 / GLib problems :(
 
while trying to install XChat, i get told one of the packages i need installed is gtk+2.0 ... so i go to the gtk website and download all of the things i need to install gtk+ (pango, atk, glib)... so the first things i install are the dependencies of those files (pkgconfig, libpng, etc.) ... that all goes fine... i then install glib-2.2.2 which also goes fine.... but when i try to ./configure either atk or gtk+ itself, i get told that i don't have glib-2.0 or above installed, but as i said i just installed it.... it says i need to add the directory containing "glib-2.0.pc" to pkg-config's "PKG_CONFIG_PATH" environment variable... i am totally lost lol... i even tried an `updatedb' but that didn't work...
:Pengy:
btw... im using mandrake linux 9.1

acid_kewpie 07-31-2003 04:27 PM

you need to install the -devel packages, which contain the actual layout of the libraries needed to compile software.

you're on mandrake though. typing "urpmi xchat" should automatically install everything for you. and even if it doesn't all the needed files will be on your distro cd's so you don't need to download anything extra

Thetargos 07-31-2003 05:07 PM

Just for the record, you may have installed the libraries into a non standard (or not included on ld.so.conf) location, you also may have skipped to run ldconfig after those libraries installed. Anyway, the best (easy) way to install software on an RPM based distribution, is to get RPM packages... so if you install the ones supplied on your CD or by urpmi, you'll have nothing to worry about!

Peace!

Thetargos.

fig 07-31-2003 05:21 PM

when I installed these, I got a similar problem. Obviously there is an order in which the individual packages need to be installed.

For my distribution - redhad 7.1, I had to modify the ld.so.conf file to lnclude the /usr/local/lib path and then run

ldconfig -v

to update everything. I eventlually ran it after each package was installed and that worked for me.


All times are GMT -5. The time now is 11:48 AM.