Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 10-10-2002, 09:05 AM   #1
Registered: Oct 2002
Distribution: Slackware 8.1
Posts: 33

Rep: Reputation: 15
xauth: timeout in locking authority file ~/.Xauthority?

Hello all!

This is my first post to this forum, but I have learned so much already. I have been using slackware for about a year, but yesterday I put 8.1 on the machine, with few problems. This time I decided to get my new wireless NIC installed, and that, too, went without a hitch. (My comp is a Dell Inspiron laptop, by the way).

So, here's my question. Yesterday, I created a user account for myself, Bryan, and set up my fluxbox prefs and such, no problem. While logged in as Bryan, I used my wireless network, and I also suspended the computer (kapmd running) for a little while. THEN, last night, I tried startx from my Bryan account, X started very slowly, and gave me this error 4 times before starting, and once as it exited:

xauth: timeout in locking authority file /home/bryan/.Xauthority

My root account started X no problem. Also, under Bryan I could do xinit and then do fluxbox with no problem. I did not have my wireless NIC in, by the way.

So, I created another user, Bibb, which generated a fresh copy of the .Xauthority file, and had no trouble starting X.

THEN, this morning my Bibb account experienced exactly the same problem. Even after fluxbox started, things weren't working right, as I expected. Mozilla would not boot, for example. I am currently connected through the network, typing this message in my third personal account in 2 days, and it's working fine.

Any ideas? Do I need to create a new account each time I use my computer? ;-)

Old 10-11-2002, 08:52 AM   #2
Registered: Oct 2002
Distribution: Slackware 8.1
Posts: 33

Original Poster
Rep: Reputation: 15
Turns out, when I installed some software to my home directory, I had screwed up the ownership and permissions settings, so that I had no write access to my own home directory. Not optimal, to be sure.

The problem was that xauth could not modify the .Xauthority file to "lock" it, hence the error message.

Just thought I'd update, in case anyone's interested.

Old 08-06-2008, 05:45 AM   #3
LQ Newbie
Registered: Aug 2008
Posts: 1

Rep: Reputation: 0
Fix - X11 timeout in locking authority file

Perfect, have been waiting for a fix for a while and your post confirmed the same problem,

After chmod & chgrp whole <user> directory to that of the user it began working properly without error.

Old 11-15-2009, 01:07 AM   #4
LQ Newbie
Registered: Aug 2009
Distribution: Slackware
Posts: 12

Rep: Reputation: 0
Thank you, I hope that this will help me, as well.
Old 05-24-2012, 08:21 AM   #5
LQ Newbie
Registered: Mar 2012
Posts: 4

Rep: Reputation: Disabled
Another Solution

Got the same "timeout in locking ...." and finally figured out
I was logging in using "ssh -Y" when no X-server was started on
the destination host. My choices are, since I'm the admin,
boot the machine in RunLevel-5 (X) or just do plain "ssh".
(Oh, and it took a long time to complete login process.)
Old 09-18-2012, 05:07 PM   #6
LQ Newbie
Registered: Mar 2012
Posts: 4

Rep: Reputation: Disabled
Yet Another Solution

Was getting the same "time out while trying to lock .Xauthority .."

Turns out that selinux was set to "Enforcing".
One either needs to change settings on $HOME
directories (I had created them manually) or change
the security level to "Permissive" or "Disabled"
in /etc/selinux/config and re-boot.
Old 08-28-2013, 02:42 PM   #7
LQ Newbie
Registered: Jun 2011
Location: Mission Viejo, CA
Distribution: Fedora 9, 13 and 15.
Posts: 16

Rep: Reputation: Disabled
Setting home directory context

Rather than disabling selinux, one can also change the context of the user's home directory.

To find out what the context is, use the -Z option on ls. Note that for a directory, you may also need to use -d option. For example, to get the context of my home directory, I did: "ls -Zd $HOME" and got the following:

drwx--x--x. carlson carlson unconfined_u:object_r:user_home_dir_t:s0 /home/carlson
To set the context, use the chcon command. You probably need to be root in order to do this. You can look at the man page, but a command like: "
chcon 'unconfined_u:object_r:user_home_dir_t:s0' $HOME

I would not change directory context arbitrarily. For example, if you have an Apache server running from /var/www and you've created a user apache whose home directory is /var/www, you don't want to change the context (which was

Note there are 4 fields:
You can read about selinux contexts here:


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
xauth: timeout in locking authority file //.Xauthority karlrb Linux - Software 2 10-26-2006 07:53 AM
xauth.... time out locking file .Xauthority DraaX Slackware 17 12-01-2004 01:19 AM
xauth: timeout in locking .Xauthority mcd Slackware 1 11-03-2004 02:42 AM
Xauth will not unlock a file at /home/username javpra Linux - Newbie 3 09-08-2004 08:36 PM
error in locking authority file Spyder23 Linux - Newbie 1 06-22-2002 12:34 AM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:54 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration