LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-03-2014, 08:24 PM   #1
sateel
LQ Newbie
 
Registered: May 2014
Posts: 4

Rep: Reputation: Disabled
X11-6 reinstall error


Hey,I have a problem with x11-6 library,which reinstall from .deb packet manually,not from repository (im using wheezy),when tried to build some tool from source.

[ERROR] [RAM Adjusted Desktop Starter] Could not start kdm

Now as see from system information,i have 2.1.6.0-1 installed,its not even jessie,sid or squeeze,wheezy have libx11-6 (2:1.5.0-1+deb7u1) version,i dont understant how i get it.When i reinstall x11,it broke the whole system.Also library dependencies with libc6 and libx11-dev.

I googled libx11-6 (2.1.6.0-1) and have only 1 result,thats smt weird,if someone knows how to fix this i would be appreciate.

libx11-6 - This package provides a client interface to the X Window System, otherwise known as 'Xlib'. It provides a complete API for the basic functions of the window system.
libx11-dev - X11 client-side library (development headers)
libc6 - Embedded GNU C Library: Shared libraries
 
Old 05-04-2014, 05:25 AM   #2
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 15,856
Blog Entries: 9

Rep: Reputation: 4644Reputation: 4644Reputation: 4644Reputation: 4644Reputation: 4644Reputation: 4644Reputation: 4644Reputation: 4644Reputation: 4644Reputation: 4644Reputation: 4644
the answer is simple:

you should not have done that. you should have used apt.

x11 libraries are essential for your (graphical) system.

most probably there would have been a different solution to your original problem (compiling some tool from source).

yes, you borked your system.
you can still try to fix it from command line (maybe as simple as running a full system update).

please get aquainted with debian's packet management.

Last edited by ondoho; 05-04-2014 at 05:27 AM.
 
Old 05-05-2014, 02:12 PM   #3
sateel
LQ Newbie
 
Registered: May 2014
Posts: 4

Original Poster
Rep: Reputation: Disabled
)) ,yes i know,that was my mistake.I guess problem was in resolution,thats why i did it.

System update working fine,but when try for example to install libx11-6 have such info:

The following packages have unmet dependencies:
libx11-6 : Depends: libc6 (>- 2.15) but 2.13-38+deb7u1 is to be installed
libx11dev : Depends: libx11-6 (2.1.5.0-1+deb7u1) but 2:1.6.0-1 is to be installed
E:Unmet dependencies

System locked,as i guess,it just need to reinstall libx11-6 packet version from already installed 2.1.6.0-1 to 2.1.5.0-1+deb7u1,but there is a problem how to do it.

please get aquainted with debian's packet management.

thanks,i tried,but because of dependencies,it doesnt help.

Here is two screenshots:

http://i58.tinypic.com/2zyc4n8.jpg
http://i62.tinypic.com/20jslqr.jpg
 
Old 05-05-2014, 04:09 PM   #4
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 15,856
Blog Entries: 9

Rep: Reputation: 4644Reputation: 4644Reputation: 4644Reputation: 4644Reputation: 4644Reputation: 4644Reputation: 4644Reputation: 4644Reputation: 4644Reputation: 4644Reputation: 4644
as i said, you borked your system.

2 solutions:

a) learn a LOT more about linux & debian, then try to fix it.
b) completely reinstall your operating system.

Last edited by ondoho; 05-05-2014 at 04:11 PM.
 
Old 05-07-2014, 06:51 AM   #5
sateel
LQ Newbie
 
Registered: May 2014
Posts: 4

Original Poster
Rep: Reputation: Disabled
The problem already solved,this thread could be closed or else,thanks.
 
Old 05-07-2014, 03:20 PM   #6
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 15,856
Blog Entries: 9

Rep: Reputation: 4644Reputation: 4644Reputation: 4644Reputation: 4644Reputation: 4644Reputation: 4644Reputation: 4644Reputation: 4644Reputation: 4644Reputation: 4644Reputation: 4644
why is this solved?
if you found a solution, please share it. others might benefit.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] GRUB reinstall error Sayan Acharjee Linux Mint 1 02-14-2011 03:12 PM
yum reinstall xorg-x11 not working vinaytp Linux - Newbie 9 11-02-2009 11:57 PM
Grub error 15 at boot, error 20 at reinstall serafean Linux - Software 4 08-17-2006 02:47 PM
X error I need to reinstall flebber Linux - Software 3 05-04-2006 04:07 AM
Can't reinstall bootsplash error 10 twinkers Debian 3 12-11-2005 05:21 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration