-   Linux - Software (
-   -   X Windows Server - GNOME - Server Configuration (

Label2021 01-05-2010 01:20 AM

X Windows Server - GNOME - Server Configuration
I am trying to get an X window server setup on my CentOS 5.3 server rack. I have gotten as far as to doing:

yum groupinstall "X Window Sever" "GNOME Desktop Environment"

EDIT-Forgot to mention that I did Xorg -configure before testing the config. Only errors I got were:

(EE) LoadModule: Module ati_r500 does not have a ati_r500ModuleData data object.
(EE) Failed to load module "ati_r500" (invalid module, 0)

And then starting the test by

X -config /root/

The test seemed to work our fine without any reported errors, besides the VNC connection which reported that I had no password authentication set to I could not login to see a GUI display. I then tried using 'vncpasswd' to set a password, it took that, but X did not recognize the change. Anyways, after this, I moved the temporary config to etc/X11/xorg.conf

I then tried to startx with reported errors. Here is my output

xauth: creating new authority file /root/.serverauth.15130

X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Linux 2.6.18-53.1.14.el5PAE i686 Red Hat, Inc.
Current Operating System: Linux server1.******.com 2.6.18-164.9.1.el5 #1 SMP Tue Dec 15 21:04:57 EST 2009 i686
Build Date: 03 September 2009
Build ID: xorg-x11-server 1.1.1-48.67.el5
Before reporting problems, check
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jan 4 06:41:41 2010
(==) Using config file: "/etc/X11/xorg.conf"

Mon Jan 4 06:41:41 2010
vncext: VNC extension running!
vncext: Listening for VNC connections on port 5900
vncext: created VNC server for screen 0
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Multiple symbols for level 1/group 1 on key <I5F>
> Using XF86Sleep, ignoring XF86Standby
> Warning: Symbol map for key <I5F> redefined
> Using last definition for conflicting fields
Errors from xkbcomp are not fatal to the X server
localuser:root being added to access control list
No profile for user 'root' found
** Message: Could not connect to power manager: Could not get owner of name 'org.gnome.PowerManager': no such name
Initializing nautilus-open-terminal extension

** (eggcups:15228): WARNING **: IPP request failed with status 1030

** (eggcups:15228): WARNING **: IPP request failed with status 1030

** (nm-applet:15261): WARNING **: No connections defined
Introspect error: Launch helper exited with unknown return code 0
could not attach to desktop process

Now I figure that the default configuration for the X server would not be prepared to run on a server environment without an actual video card/keyboard/mouse/etc so I think that this is my problem. However I have not found any documentation as to how to configure an X server for a server environment, and I have searched for hours only to find a couple tutorials on configuring an X server for a regular desktop environment. My aims are to get GNOME up and running, and a working VNC connection which I already have ( If anyone could provide link to a how to/tutorial that would be great, or maybe just what I am doing wrong here. Thank you much

CentOS 5.3

Linuxquestions--I posted this over on the CentOS forums, which are not as booming. Then I remembered these forums for when I had my VPS way back when and you guys were pretty helpful, of course expected me to mostly do my own reading which I dont mind its just having a hard time understanding some of the things in what I was reading. I even believe I came here with this problem before but abandoned the issue because my VPS was not powerful enough or something of the sort, but this was many years ago also on CentOS using apt. Now using yum which I like much better. Good to see you guys again.

ongte 01-05-2010 07:28 AM

Try using the system-config-display tool.

Label2021 01-05-2010 03:54 PM

The system-config-display command returned nothing but a blank line. I had to ctrl-c out. I also got the same result when running 'setup' and then 'X configuration' so I was under the impression it wanted me to write my own config or something. Im guessing this probably isnt the case?

Label2021 01-06-2010 12:03 AM

Please tell me I am not stuck paying my host an hours work to configure the X window server/GNOME on my server? Nobody has ever tackled setting this up and configuring it for emulated hardware? Ive read of it being done, but simply havent found documentation about it anywhere using google.

All times are GMT -5. The time now is 07:51 PM.