-   Linux - Software (
-   -   X windows not appearing, root window refresh problem (

kdogksu 12-28-2004 05:29 PM

X windows not appearing, root window refresh problem
I just installed debian linux on an old K7 machine, and am having trouble getting X to work. My graphics card is an NV MX4000. I have downloaded and installed the most recent driver from nvidia, and updated the appropriate settings for the driver in XF86Config-4. I am using IceWM as my window manager. When I run startx, the NVIDIA splash screen appears and IceWM seems to start up okay; the toolbar appears, I can navigate the menus, and the clock runs. However, nothing on top of the root window appears to refresh. If I open the menu and then click elsewhere, the menu does not disappear. Running a windowed program (e.g. xterm) brings up the title bar for the program, but no window for the program. However, I am able to use the xterm (e.g. 'echo test > file.out' and check in console). The title bar itself has patches of pixel noise (i.e. seemingly random colored pixels in it). My .xinitrc file contains only 'icewm-session'. Any ideas? Sorry if this issue has been covered before... this is a hard issue to describe as a search string. Thanks!

XFree86 Version
Kernel 2.6.6
Debian - testing

kdogksu 12-29-2004 02:12 AM

Still haven't figured this out.... I've tried lots of alterations in XF86Config-4 with no success. I've tried using vlwm and uwm window managers and both seem to have the same root refresh problem, so it's not the window manager. I can run graphical programs just fine: putting glxgears in my .xinitrc file (not running the wm) causes it to run on top of the nvidia splash screen that remains on the root window. It gets nearly 1000fps, which seems to indicate that 3d acceleration (and thus the nvidia driver) is working fine. I checked my kernel and framebuffer support is not compiled in, which is how it should be for nvidia drivers. I'm very much at a loss for what to do next. Any help would be appreciated! Thanks.

beanerjo 12-29-2004 05:40 AM

I had the same problem with my NVidia TNT2. Strange is that I had no problem until one day I upgraded to X11R6.8, kernel 2.6, and to the latest nvidia driver. I changed kernel back to 2.4, but the problem was still there; I tried older nvidia drivers which used to work, but no avail. But I haven't tried with older X. I don't think it is related with window managers. (It worked slightly better with "Metacity+Gnome Panel" but was not perfect.) I rather think the problem comes from some shared libraries. (It may be the case I upgraded the libraries only partially.) Instead of spending more time and energy, I decided to simply use "nv" (in X) instead of "nvidia" (provided by NVidia) and give up some fancy features.

ncc1701 01-18-2005 05:32 AM

What nvidia drivers version are You using?

beanerjo 01-18-2005 06:39 PM

At first 6106 was working, and then I tried 6629 but it didn't work. So I changed back to 6106 to find that it didn't work anymore! So I tried 5336 (I read about 5336 from some list, thanks), and now it is working.

ncc1701 01-19-2005 04:59 AM

I had imilar problem with 6629, but 6111 is working fine.

kdogksu 01-21-2005 07:26 PM

6629 still gives me the same problem. I have tried 6111, but the kernel module will not install. It complains that __VMALLOC_RESERVE is an unknown symbol. This problem is noted in other places, and even has a patch. I tried the patch with no luck. It is a problem with 6111 and newer kernels. I have to use 2.6.9 or similar so that I can use the ivtv drivers for my capture card, so I can't use a different kernel. I also tried 5336, which is not supposed to have the VMALLOC_RESERVE problem, but I still get the same error. I have tried --extract-only and building myself, but still have the same problem. I have specified my source directory with --kernel-source-path, but that doesn't help. The driver builds fine (well, with lots of warnings, but no errors...), but cannot be installed. Any suggestiongs? Thanks!

ncc1701 01-22-2005 11:07 AM

6111 compiled fine but there were two issues while loading module:
1. Unknown symbol __VMALLOC_RESERVE
2. Unknown synbol pci_find_class()
edit nv.c and put there: unsigned int __VMALLOC_RESERVE
edit nv.c and change all pci_find_class() to pci_get_class()

so extract, make changes and simply run installer.

All times are GMT -5. The time now is 06:22 PM.