LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-18-2017, 02:47 PM   #1
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (current), FreeBSD, Win10, It varies
Posts: 9,952

Rep: Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148
X-Term garbage chars on CLI right at start up.. how to make it not do that.


RIght at the bottom where the $ is their is the "symbols" used to denote whatevers in the prompt I think

this is my .bashrc for my prompt.
Code:
PS1="\u@\H⚡\w $"
It has been doing that every sense this install of Slackware - as I do not use x-term very often. only in certain cases. I've just back them chars off then typed in what I need. still it is not suppose to be doing that. it was not doing that in the prior installs but now is.

this is my /etc/inputrc
Code:
userx@slackwhere⚡~ $cat /etc/inputrc
# /etc/inputrc
# This file configures keyboard input for programs using readline.
# See "man 3 readline" for more examples.
# Configure the system bell.  Options are none, visible, and audible.
#set bell-style none
# Enable 8 bit input.
set meta-flag On
set input-meta On
set convert-meta Off
set output-meta On
# Set various nice escape sequences:
"\eOd": backward-word
"\eOc": forward-word
# for linux console
"\e[1~": beginning-of-line
"\e[4~": end-of-line
"\e[5~": beginning-of-history
"\e[6~": end-of-history
"\e[3~": delete-char
"\e[2~": quoted-insert
# for xterm
"\eOH": beginning-of-line
"\eOF": end-of-line
# for freebsd console
"\e[H": beginning-of-line
"\e[F": end-of-line




"\e[3~": delete-char
# this is actually equivalent to "\C-?": delete-char
# VT
"\e[1~": beginning-of-line
"\e[4~": end-of-line
# kvt
"\e[H":beginning-of-line
"\e[F":end-of-line
# rxvt and konsole (i.e. the KDE-app...)
"\e[7~":beginning-of-line
"\e[8~":end-of-line
## enable Alt-arrows 
"\e[1;5D": backward-word
"\eOd": backward-word
"\e[1;5C": forward-word
"\eOc": forward-word
I cannot off the top of my head think of anything else that'd be causing it.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_X-Term-gooba-2017-04-18_14-39-16.png
Views:	23
Size:	11.6 KB
ID:	24801  
 
Old 04-20-2017, 02:07 AM   #2
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 16,482

Rep: Reputation: 5530Reputation: 5530Reputation: 5530Reputation: 5530Reputation: 5530Reputation: 5530Reputation: 5530Reputation: 5530Reputation: 5530Reputation: 5530Reputation: 5530
if this garbage is part of the prompt (=displayed every time together with your prompt) you need to check your PS1. Try to set it to something simple, like '> ' to check if that was true.
If that garbage displayed only at startup you need to check man bash, look for INVOCATION and examine all the files loaded during startup.
 
Old 04-20-2017, 08:28 AM   #3
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (current), FreeBSD, Win10, It varies
Posts: 9,952

Original Poster
Rep: Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148
Quote:
Originally Posted by pan64 View Post
if this garbage is part of the prompt (=displayed every time together with your prompt) you need to check your PS1. Try to set it to something simple, like '> ' to check if that was true.
If that garbage displayed only at startup you need to check man bash, look for INVOCATION and examine all the files loaded during startup.
I did not want to hear that (said in jest)

it does look like that output that is there after the prompt is not something a prompt would use.

after the $ in the prompt
Code:
64;1;2;6;9;15;18;21;22c
As this is X Term specif it does not occur with any other terminal - elum I start whatsoever.

so yeah -- got a dig in

Last edited by BW-userx; 04-20-2017 at 08:31 AM.
 
Old 04-20-2017, 08:31 AM   #4
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 16,482

Rep: Reputation: 5530Reputation: 5530Reputation: 5530Reputation: 5530Reputation: 5530Reputation: 5530Reputation: 5530Reputation: 5530Reputation: 5530Reputation: 5530Reputation: 5530
How do you know if it was only xterm related? Did you try to modify PS1? Did you try another term?
 
Old 04-20-2017, 08:33 AM   #5
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (current), FreeBSD, Win10, It varies
Posts: 9,952

Original Poster
Rep: Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148
Quote:
Originally Posted by pan64 View Post
How do you know if it was only xterm related? Did you try to modify PS1? Did you try another term?
process of elimination

they all use
.bashrc

open up all of my other terminals

results

x Term is the only one doing this.

I was just about to do that prompt thing just to eliminate it anyways .. hold on.

I stand corrected

it is this within the prompt
Quote:
X -Term does not know how to deal with it, obviously.That is why it is doing what it is doing.

now I need to know how to get that font to work (again) in X-Term.

it was something that "just worked" for whatever reasons. Now on this install it does not.

to further enplane, It then had to be something I did in relationship to something that got it to just work. whatever that was. it is in the unknown with me.

Last edited by BW-userx; 04-20-2017 at 08:40 AM.
 
Old 04-20-2017, 09:00 AM   #6
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (current), FreeBSD, Win10, It varies
Posts: 9,952

Original Poster
Rep: Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148
would this be referred to as a UTF-8 'special character'? So I can know that'd be a good starting place to look into this.



Code:

Last edited by BW-userx; 04-20-2017 at 09:03 AM.
 
Old 04-21-2017, 08:27 AM   #7
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
You could try to set the font.

Code:
xterm -b 0 -bw 0 +sb -fg rgb:99/99/99 -bg rgb:00/00/00 -cr rgb:ff/ff/00 \
      -fn -*-neep-medium-r-normal-*-20-* \
      -fb -*-neep-bold-r-normal-*-20-*
 
Old 04-21-2017, 09:21 AM   #8
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (current), FreeBSD, Win10, It varies
Posts: 9,952

Original Poster
Rep: Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148
Quote:
Originally Posted by Shadow_7 View Post
You could try to set the font.

Code:
xterm -b 0 -bw 0 +sb -fg rgb:99/99/99 -bg rgb:00/00/00 -cr rgb:ff/ff/00 \
      -fn -*-neep-medium-r-normal-*-20-* \
      -fb -*-neep-bold-r-normal-*-20-*
due to a tar.gz File I have that would not untar and giving me a UTF-8 error I changed my locate from LANG=en_US to LANG=en_US.UTF-8 that fixed that issue, now that i just checked x-tem due to your post. I see that it stopped outputting that stuff to the cli but still is not showing the lightning bolt. which is only aesthetics and I do not use x-term too much even though I do like how it looks - but - it not having basic copy paste keyboard controls even. I do not use it that much to worry about it that much.

the much I did worry about is now gone. to I am worry free about X-Term ... thanks
 
Old 04-21-2017, 10:16 AM   #9
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
gnome terminal has Control+Shift+V to paste, so there is that (at least in ubuntu). There's a general X clipboard, last thing highlighted and middle mouse to paste. And other options. I tend towards urxvt, but sometimes I'm too lazy to venture past xterm.

I never used slack long enough to know what method to reconfigure locales. But in debian.

$ sudo dpkg-reconfigure locales

Setting LANG and LC_ALL manually works too.
 
Old 04-21-2017, 10:32 AM   #10
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (current), FreeBSD, Win10, It varies
Posts: 9,952

Original Poster
Rep: Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148
Quote:
Originally Posted by Shadow_7 View Post
gnome terminal has Control+Shift+V to paste, so there is that (at least in ubuntu). There's a general X clipboard, last thing highlighted and middle mouse to paste. And other options. I tend towards urxvt, but sometimes I'm too lazy to venture past xterm.

I never used slack long enough to know what method to reconfigure locales. But in debian.

$ sudo dpkg-reconfigure locales

Setting LANG and LC_ALL manually works too.
yeah I know the short cuts, and highlight middle button trick, it is what X-Term still lacks keyboard Control+Shift+C Control+Shift+V and ...

it is an old out dated not updated term that is still used as a standard default type - even other terminals use x-term for its emulation settings

it is just a nice small little white box that can be colored even .. not one of them bigger terms. that is just nice to use now and then. I do suppose if it did have all of the functionalities built in like copy paste KB and Mouse right click and split windows like terminator .. that'd be the cats pajamas

Last edited by BW-userx; 04-21-2017 at 10:35 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] sed: replace regexp w/ variable #s of chars with the same # of (diff.) chars? kmkocot Linux - Newbie 6 11-18-2011 05:36 AM
Echo sequence of numbers with '0' padding for length of 3 chars in CLI koobi Programming 9 11-16-2009 04:40 AM
single quotes represented by garbage chars in perldoc echowarpt Slackware 3 05-26-2007 11:03 AM
Odd Chars w/ make/C++ compile error on Fedora w/bash shell zemux Linux - General 2 01-22-2006 01:48 AM
start mozilla through x term bm1 Slackware 7 03-09-2004 11:39 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration