-   Linux - Software (
-   -   X server + 2 users != work (

vexer 07-29-2003 11:35 AM

X server + 2 users != work
I have 2 different users on 1 local pc. Now for some reason I get a Invalid MIT-MAGIC-COOKIE-1 when I have 1 user using X and the other trying to start using X with startx -- :1.

Could the tcp nolisten flag have this affect? is there a way around this?


vexer 07-29-2003 12:09 PM

Turns out it was tcp nolisten, but I would like to know if there is a way to still use tcp nolisten and have multiple WM's running.


Corin 07-29-2003 08:15 PM

In which configuration file is the tcp nolisten option located?

yitzhakbg 07-30-2003 10:12 AM

Multi-user local X
Go to and you will have true multi-user local X windows. I have three users working comfortably one one PC.

vexer 07-30-2003 11:37 AM

Corin, you edit the startx script (/usr/X11R6/bin/startx
) and add -tcp nolisten to the serverargs="" line.

Corin 07-30-2003 02:29 PM


man XFree86

On most platforms, the "Local" connection type is a UNIX-domain
socket. On some System V platforms, the "local" connection types
also include STREAMS pipes, named pipes, and some other mechanisms.

XFree86 listens on port 6000+n, where n is the display number.
This connection type can be disabled with the -nolisten option (see
the Xserver(1) man page for details).

So do you have two keyboards and two mice attached to the PC?
If so, I misunderstood what it was you were trying to do.

yitzhakbg 07-30-2003 03:15 PM

The site I referred you to, is true multi-user. Every user (we have three) has his own X session running on his own screen, KB & mouse. All three work away merrily feeling entirely that they are alone on the machine. No networking, socket or other such complications. It's great.

All times are GMT -5. The time now is 04:55 PM.