-   Linux - Software (
-   -   X segfaults on startup... please help :( (

Napalm Llama 08-04-2005 02:55 PM

X segfaults on startup... please help :(
I rebooted earlier today, only to find that Xorg has stopped working! I don't know why it's done it, but there it is.

I've tried everything I can think of (reinstalling the nvidia drivers, disabling all the modules in /etc/X11/xorg.conf, even reinstalling X itself) but to no avail.

Here's my /var/log/Xorg.0.log:


X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.12-gentoo-r6-splig-X0 x86_64 [ELF]
Current Operating System: Linux splig 2.6.12-gentoo-r6-splig-X1-scsi #5 Thu Aug 4 20:23:24 UTC 2005 x86_64
Build Date: 04 August 2005
        Before reporting problems, check http://wiki.X.Org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Aug  4 20:27:22 2005
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Local Layout"
(**) |-->Screen "MainScreen" (0)
(**) |  |-->Monitor "CTX 1569se"
(**) |  |-->Device "GeForce 6600 GT"
(**) |-->Input Device "Keyboard (zippy)"
(**) |-->Input Device "PS/2 Scroll Mouse"
(WW) The directory "/usr/share/fonts/CID/" does not exist.
        Entry deleted from font path.
(==) FontPath set to "/usr/share/fonts/misc/,/usr/share/fonts/TTF/,/usr/share/fonts/Type1/,/usr/share/fonts/75dpi/,/usr/share/fonts/100dpi/"
(==) RgbPath set to "/usr/lib64/X11/rgb"
(==) ModulePath set to "/usr/lib64/modules"
(WW) Open APM failed (/dev/apm_bios) (No such file or directory)
(II) Module ABI versions:
        X.Org ANSI C Emulation: 0.2
        X.Org Video Driver: 0.7
        X.Org XInput driver : 0.4
        X.Org Server Extension : 0.2
        X.Org Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/lib64/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="X.Org Foundation"
        compiled for 6.8.2, module version = 1.0.0
        Module class: X.Org Font Renderer
        ABI class: X.Org Font Renderer, version 0.4

  *** If unresolved symbols were reported above, they might not
  *** be the reason for the server aborting.

Fatal server error:
Caught signal 11.  Server aborting

Please consult the The X.Org Foundation support
        at http://wiki.X.Org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

My system specs are down there, in my sig.

Does anybody know how to help me? I don't have a clue :(

Zeistler 08-05-2005 12:36 AM

I had a similar problem a while back, it was really weird. What I did was to change the Driver "Keyboard" entry in the keyboard input device section to Driver "keyboard" (small letters) then it worked.

Napalm Llama 08-05-2005 04:40 AM

When I updated to the latest version (just a Gentoo patch I think) it changed the name of that driver to "kbd" - but I'll have a play around with my config file anyway, see if it helps. Thanks!

Napalm Llama 08-06-2005 06:02 AM

Sorry for bumpage, but this had fallen a long way down the forum, and I just realised that one of the last things I did with my working Xorg was install Wine and use it to run Photoshop 4 (I'm poor) and Pro/Desktop (a pretty much unsupported-in-Wine CAD package) - P/D didn't work at all with hardware acceleration disabled, but when I enabled it it presented me with a drawing area (albeit in the wrong place) - however, it got slower and slower, and in the end I had to force-quit it.

Could any of this have damaged my X server?

I just want to get my desktop back... :(

I fiddled with my xorg.conf in every way I could think of, but the only way I could avert the segfault was by doing things which made Xorg spit the file back at me, saying it was invalid...

[further edit]
I've discovered that if I remove /usr/lib64/modules/fonts/libbitmap.a, Xorg fails to load the module "bitmap", and complains that it's "unable to load required base modules." It then exits - but without segfaulting.
Thing is, I don't think it's the module itself that's to blame, because I copied the libbitmap.a across from my (working) FC4 installation, and tried that instead. It made no difference whether I used the "real" Gentoo one, or the FC4 one - X segfaulted in just the same way.

Has any of this given anybody enough to go on? I still don't know what to do :(

All times are GMT -5. The time now is 01:22 PM.