LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   X/gnome messed up after <unstable> upgrades. (https://www.linuxquestions.org/questions/linux-software-2/x-gnome-messed-up-after-unstable-upgrades-713286/)

prushik 03-20-2009 11:42 PM

X/gnome messed up after <unstable> upgrades.
 
I recently decided to take a chance and install some unstable upgrades (I love unstable things). So I upgraded many of my applications via apt-get. One of the big things I upgraded was libc6. I think that my be the issue, not sure. After the upgrades, I had many many problems. I was able to fix nearly all of them in different ways, many by downgrading, others by changing permissions (somehow root stole my home folder and made it read-only to regular users). However, one issue still remains: gnome will not start. X was upgraded, but I removed and reinstalled a stable version. When I run 'startx' I get an X display (checkerboard) with the pointer in the middle. I can not move the pointer and no windows manager loads. If I run "startx gnome-session" or "startx gdm" or "xinit /usr/bin/gnome-session" the screen flashes and I am returned to the console. any X errors are already off the screen by the time I get back to the console, and i couldnt redirect the output to a file for some reason.
I tried reinstalling x, gnome, gdm, and xterm, but it didnt help. Also, i tried to downgrade libc6 and it wanted to remove coreutils and apt and other very important packages. So I havent done that.
Any advice?
Thanks in advance everybody, I feel pretty dumb right now, I'd like to get this working again.

I also posted on daniweb, heres a link to my daniweb post: http://www.daniweb.com/forums/thread182594.html
I'm also posting here because linuxquestions is much more linux focused and frequented (besides mine, last daniweb topic on the linux software forum was from feb. 10)

asymptote 03-21-2009 03:37 AM

I don't understand why you would enable unstable upgrades but assuming you are using Ubuntu or other Debian based system, just go to Synaptic Package Manager, edit repositories, and deselect "proposed" or "backports" repositories. Reload your repositories and you should be able to revert back to normal.

prushik 03-21-2009 02:01 PM

Well that would be nice. But for one, I don't think that even synaptic can do a "mass downgrade", which is what I need. And another thing. I can not run gnome, so I therefore can not run Synaptic. I'm stuck using terminal programs like apt and dpkg until I get gnome running. But one of the first things I did was remove the unstable repositories from sources.list.
Quote:

I don't understand why you would enable unstable upgrades
Because they are the best! Unstable upgrade may contain new features that the rest of the world hasn't seen yet! And they usually work for the most part.

By the way, my system was Ubuntu Intrepid Ibex 8.10

asymptote 03-21-2009 03:01 PM

They certainly may be the best and I was just speaking from personal experience. Usually enabling all those repos gives me a lot of trouble but if you like enabling them then so be it. I'm not sure how to do a mass downgrade - i'll google and see what I can find.

prushik 03-21-2009 04:05 PM

Well, I have been searching on google for the answer. I have come across a few places that suggest using apt-get pinning to downgrade. However, i checked and I don't have the /etc/apt/preferences file. Which seems to be normal and I can create it from scratch, but I haven't tried it yet, I was hoping for another solution. But I'll give it a shot. I'll just have to write down what it should look like on paper. Or I could create the file on my windows machine and copy it over, that would be better I think.

Anyway, I did manage to do a partial mass downgrade. I downgraded my base system to the Intrepid original versions using "debootstrap --download-only intrepid ~/ibex" and then "dpkg -i ~/ibex/var/cache/apt/archive/*.deb". Nobody told me to try that, but I thought it should work. And it did successfully downgrade my base system, but that doesn't include gnome or X or anything. and I still can't start gnome. So I'm back where I started. But I think that rules out the issue being caused by libc6, because that has been downgraded.

So I'm still stuck. But I'll try pinning and tell you what the results are. I now fear that even a mass downgrade may not solve my problems. I really don't want to start over, all though that could be fun.


All times are GMT -5. The time now is 04:27 AM.