Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 08-30-2005, 02:03 PM   #1
LQ Newbie
Registered: Aug 2005
Location: Louisville, KY
Distribution: Debian Sarge
Posts: 29

Rep: Reputation: 15
X forwarding via SSH

I opened /etc/ssh/ssh_config and turned the XFowarding option from off to on...saved, restarted sshd

didnt i went back and uncommented it (took off the #)..saved, restarted

no beans....i remembered it was easier than this the last time i did it, but one of my buddies told me step by step how to do it, and I forgot now.....
Old 08-30-2005, 02:12 PM   #2
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
ssh_config is the client config. If you want to change the server options then edit sshd_config.
Old 08-30-2005, 05:10 PM   #3
Registered: Aug 2003
Location: Colorado, USA
Distribution: Fedora Core
Posts: 100

Rep: Reputation: 15
Just as an FYI, I used to use ssh X11 forwarding to forward stuff from home to work but I found that using VNC through ssh was much more faster and snappier. Maybe it's because the X11 server I'm using at work is through cygwin where as VNC is native. Not sure, but I stopped using X11 forwarding through ssh because it was too slow (I only have 384kbps up at home). Of course this is just my experience and your may vary.
Old 08-30-2005, 05:35 PM   #4
LQ Newbie
Registered: Aug 2005
Location: Louisville, KY
Distribution: Debian Sarge
Posts: 29

Original Poster
Rep: Reputation: 15
didn't work either......

it did work before though....anybody know why it doesnt now....

I get the display not found error when i try to launch something,like mozilla........

pretty much I just want a desktop environment that I can use to mess around with when I can't use my apple.....
Old 08-30-2005, 07:13 PM   #5
Senior Member
Registered: Aug 2005
Posts: 1,755

Rep: Reputation: 50
What OS are you ssh'ing from and what OS are you ssh'ing to? You mentioned an Apple? Are you sure you're running an X server on the computer you're ssh'ing from?

The computer you're ssh'ing into must have the "X11Forwarding" or whatever directive uncommented and set to on in sshd_config and if you change it you must restart sshd.

To enable X forwarding when you ssh you need to use the "-X" (uppercase X) flag on the ssh command (or set the "ForwardX11" or whatever directive to on in ssh_config). (In recent versions of OpenSSH, for best results, you need the "-Y" flag or the "ForwardX11Trusted" directive.)


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
SSH X forwarding krusty_lab AIX 10 01-02-2008 09:36 AM
SSH X forwarding djgerbavore Linux - Networking 1 11-17-2005 09:40 AM
Port forwarding for ssh Adriaan Linux - Networking 1 03-08-2004 09:11 AM
ssh and X-forwarding Björneborg Linux - Networking 2 02-19-2004 10:50 AM
ssh, and port forwarding Tricky Linux - Networking 3 01-06-2003 07:50 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:50 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration