LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-28-2003, 10:11 PM   #1
saimike
Member
 
Registered: Aug 2003
Posts: 71

Rep: Reputation: 15
wxgtk install help


hi there,

when i try to install wxGTK-2.4.1 (i ultimately want to have xmule-1.4.3 installed), i get this error msg when i do a "./configure":

checking for GTK+ version...
checking for gtk-config... no
checking for GTK - version >= 1.2.7... no
*** The gtk-config script installed by GTK could not be found
*** If GTK was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GTK_CONFIG environment variable to the
*** full path to gtk-config.
checking for gtk-config... (cached) no
checking for GTK - version >= 1.2.3... no
*** The gtk-config script installed by GTK could not be found
*** If GTK was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GTK_CONFIG environment variable to the
*** full path to gtk-config.
configure: error:
Please check that gtk-config is in path, the directory
where GTK+ libraries are installed (returned by
'gtk-config --libs' command) is in LD_LIBRARY_PATH or
equivalent variable and GTK+ is version 1.2.3 or above.

i tried doing a "find /usr -name gtk-config -print" and found nothing, "echo $GTK_CONFIG" got nothing either. however i did install gtk ...

[root@localhost wxGTK-2.4.1]# pkg-config --list-all
gdk-pixbuf-xlib-2.0 GdkPixbuf Xlib - GdkPixbuf rendering for Xlib
gdk-x11-2.0 GDK - GIMP Drawing Kit (x11 target)
gmodule-2.0 GModule - Dynamic module loader for GLib
gdk-pixbuf-2.0 GdkPixbuf - Image loading and scaling
gtk+-x11-2.0 GTK+ - GIMP Tool Kit (x11 target)
gnome-mime-data-2.0 gnome-mime-data - Base set of file types and applications for GNOME
fontconfig Fontconfig - Font configuration and customization library
glib-2.0 GLib - C Utility Library
gobject-2.0 GObject - GLib Type, Object, Parameter and Signal Library
gthread-2.0 GThread - Thread support for GLib
pangoft2 Pango FT2 - Freetype 2.0 font support for Pango
gtk+-2.0 GTK+ - GIMP Tool Kit (x11 target)
libpng libpng12 - Loads and saves PNG files
xcursor Xcursor - X Cursor library
libart-2.0 libart - LGPL version of the libart library
pangox Pango X - X Window System font support for Pango
pangoxft Pango Xft - Xft font support for Pango
gtk-thinice-engine-2 gtk-thinice-engine-2 - Thinice GTK+ Theme Engine
libpng12 libpng12 - Loads and saves PNG files
xft Xft - X FreeType library
pango Pango - Internationalized text handling
gtk-engines-2 gtk-engines-2 - GTK+ Theme Engines
gdk-2.0 GDK - GIMP Drawing Kit (x11 target)
atk Atk - Accessibility Toolkit

can anyone help me out here?

ps. how do i change the hostname?
 
Old 08-29-2003, 12:37 AM   #2
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 60
It looks as if you don't have the developmental packages for GTK installed.

I wonder what would happen if you give this command:

urpmi xmule

# Mandrake links
Mandrake home page
Mandrake Users website
Easy urpmi config for Mandrake
urpmi mini-HOWTO
Easy software management: Red Carpet
Maximum RPM
rpmfind
You didn't install the developmental packages? As root, command:
urpmi gcc
An Introduction to the Midnight Commander. You can install it by commanding:
urpmi mc
Midnight Commander home page
 
Old 08-29-2003, 01:59 AM   #3
saimike
Member
 
Registered: Aug 2003
Posts: 71

Original Poster
Rep: Reputation: 15
by developmental packages, do u mean gcc? if so i do have it, as i have compiled pkg-config, atk, pango, glib, and gtk just earlier this week.
 
Old 08-29-2003, 09:45 AM   #4
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 60
gcc is the compiler, but the software you are trying to install needs some gtk packages you don't have installed yet.

Try looking through your uninstalled software with the Mandrake Control Center or type:urpmi gtk and look through the list.

root@uilleann / # urpmi gtk
The following packages contain gtk: libgtk+mdk0.1_6 gtkasp2php amaya-gtk gnosamba libgtkhtml2_0-devel libgtkglarea5-devel wxGTK2.3_1 nautilus-gtkhtml php-gtk libgtkmm1.2-devel libgtk+extra0-devel libgtkhtml20 gtk+2.0 libwxgtkgl2.3_2 drakxtools rep-gtk libwxPythonGTK2.3_2-devel libwxgtk2.3_2-devel python-imaging metatheme libgtkxmhtml1 wxGTK2.3_1-gl gtk-doc libexif-gtk4-devel libgtkspell0-devel gtk+mdk perl-GTK gtk-manix hotplug-gtk pygtk-libglade ruby-gtk pygnome gtk+licq gtktetris wxPythonGTK libgtk+-x11-2.0_0-devel gtkgraph ocaml-lablgtk perl-GTK-GLArea mozilla libgnome-guile0 gtklp gtkfind wxPythonGTK-devel rep-gtk-libglade libgtk+extra0 gtkmotd libwxgtk2.3_2 wxGTK2.3_1-devel libgtk+2.0_0 glade-perl gtkhx libGConf1 gtk-theme-switch unixODBC-gui-gtk gtkdialogs gtkam libgtk+mdk0.1_6-devel gtkeyboard gtk+licq-nognome fvwm2-gtk gtkhtml libgtk+1.2-devel gtktalog vlc-gtk libgtkhtml20-devel perl-GTK-Glade perl-GTK-GdkPixbuf gocr-gtk perl-GTK-Gnome pygtk libgtk+-linuxfb-2.0_0-devel gtk+licq-base mtr-gtk libgtk+1.2 libwxPythonGTK2.3_2 pygtk-glarea libexif-gtk4 gtk-themes yank libgnome32 libgtk+-x11-2.0_0 libgtkglarea5 gtk-engines libgtkspell0 perl-GTK-GtkHTML perl-GTK-GdkImlib rep-gtk-gnome libgtkmm1.2 gtk-engines2 pygtk-devel libgtkhtml2_0 libgtkodbcconfig0 crossfire-client-gtk libgimp1.2 alsaplayer-plugin-ui-gtk wxGTK libgtk+-linuxfb-2.0_0 libgtk+2.0_0-devel

Try installing things that mention gtk and devel in that list.

Last edited by fancypiper; 08-29-2003 at 12:28 PM.
 
Old 08-29-2003, 12:10 PM   #5
saimike
Member
 
Registered: Aug 2003
Posts: 71

Original Poster
Rep: Reputation: 15
ah, i c. thanks for the clarification.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot install wxGTK and wxPython slack10 MykilX Slackware 3 10-30-2004 06:32 AM
problem to install wxGTK setlec_seta Linux - Software 0 07-13-2004 09:10 PM
wxGTK - help me! powune Linux - Newbie 4 10-25-2003 12:53 PM
lMule wxGTK and wxGTK-devel Caveman Linux - Software 3 10-15-2003 12:38 PM
wxGTK 2.4.0 vexer Linux - Software 0 05-08-2003 04:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration