LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   wrong resolution for a game... please help im going crazy!!!!!!!!!!!! (https://www.linuxquestions.org/questions/linux-software-2/wrong-resolution-for-a-game-please-help-im-going-crazy-111292/)

zexter 11-01-2003 08:50 PM

wrong resolution for a game... please help im going crazy!!!!!!!!!!!!
 
ok i downloaded a game, spent forever talkin to someone who helped me alot, i installed the game but when it would run it would extremely laggy, so then i downloaded and installed the drivers for my graphics card, now when i try to open the game (called legends) it says the resolution isnt right i need to look at the driver configureation...... this is what it says in the terminal....


[zexter@localhost Downloads]$ ./runlegends
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".


i know it has something to do with the open gl...
can someone please help me out tonight?

exodist 11-01-2003 10:52 PM

your dirver is not setup correctly. do you use nvidia or ati? if nvidia you need to install using the .run package, then you need to modify your /etc/XF86Config(-4) file and change the driver: "nv" to driver: "nvidia"
that should fix it.

zexter 11-01-2003 11:12 PM

can u explain what im suppose to do a little more please? and i dont have the /etc/XF86Config(-4) file..... so what exactly should i do?



thanks

zexter 11-01-2003 11:13 PM

oh, and i use nvidia... tnt2 graphics card

exodist 11-01-2003 11:18 PM

I meant /etc/XF86Config OR /etc/XF86Config-4 if both exist edit both, they are your x config, unless you did a custom config (in which case you would have known what I was talking about) one or both should be there

edit them so that in the video device setting the driver is changed from "nv" to "nvidia"

also before this you need to d-load the linux driver from www.nvidia.com it is a .run file

run the fiel then make above changes.

that would fix it.

but this is only if you have nvidia video card, if you have ati it is useless and I cannot help you.

I don't think it can be made any clearer than this, I can't tell you what line exactly to change, or what it looks like because distros liek rh/mandrake/suse are stupid and use very ugly x config files created by an automatic utility, and auto utils screw everything up. where as I use slack that has a very nice config file generated from a question driven util.

zexter 11-01-2003 11:26 PM

there is no /etc/XF86Config OR /etc/XF86Config-4 files at all!!!!!!

exodist 11-01-2003 11:37 PM

i am sorry, my bad /etc/X11/XF------

I appologise that was my mistake

zexter 11-01-2003 11:47 PM

ok im in the file and i found the part that says "nv" but i cant change it to nvidia, and i thought all i had to do was type in "i" to be able to edit it but i cant edit it at all.... how do i do this?


thanks for all your help

exodist 11-01-2003 11:52 PM

oh vi.. if you can get into x try gnp or gedit, in terminal try pico easyer than vi.. also you need to be logged in as root to edit the file.

zexter 11-01-2003 11:53 PM

ok thanks ill try that and ill be right back with ya...thanks for helpin

zexter 11-02-2003 12:10 AM

ok i logged on into root, and then i used vi to change "nv" to nvidia. then hit ESC but when i opened it again thru a file browser it still said "nv". how do save the changes you make?


lol im sorry i dont know more.... but thanks !

roorings 11-02-2003 12:17 AM

dood, with vi or VIM just type I to insert, then hit escape, then hit shift : key, then type w!
hit enter and its saved

w! saves.

roorings 11-02-2003 12:17 AM

shift : puts u into input mode.

zexter 11-02-2003 12:26 AM

should i do this to the back up file also?

exodist 11-02-2003 12:41 AM

cp filename newfilename, that makes backup.


All times are GMT -5. The time now is 02:38 AM.