LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Wine won't install (https://www.linuxquestions.org/questions/linux-software-2/wine-wont-install-730981/)

Wormboy 06-05-2009 01:51 PM

Wine won't install
 
I downloaded the wine 1.1.22 development binary but when I attempt to install it I get this error:

(Reading database ... 103685 files and directories currently installed.)
Preparing to replace wine 1.0.1-0ubuntu6 (using wine_1.1.22~winehq0~ubuntu~9.04-0ubuntu1_i386.deb) ...
Unpacking replacement wine ...
lzma: Decoder error
dpkg-deb: subprocess <decompress> returned error exit status 1
dpkg-deb (subprocess): failed in buffer_write(fd) (5, ret=-1): failed to write to pipe in copy: Broken pipe
dpkg: error processing wine_1.1.22~winehq0~ubuntu~9.04-0ubuntu1_i386.deb (--install):
short read in buffer_copy (backend dpkg-deb during `./usr/lib/wine/mshtml.dll.so')
* Setting kernel variables (/etc/sysctl.conf)... [ OK ]
* Setting kernel variables (/etc/sysctl.d/10-console-messages.conf)... [ OK ]
* Setting kernel variables (/etc/sysctl.d/10-network-security.conf)... [ OK ]
* Setting kernel variables (/etc/sysctl.d/30-wine.conf)... [ OK ]
Errors were encountered while processing:
wine_1.1.22~winehq0~ubuntu~9.04-0ubuntu1_i386.deb

By the way I tried removing the older wine package but that didnt solve the problem.
I'm running 32-bit Ubuntu Jaunty

rasta_freak 06-05-2009 04:00 PM

Looks like broken package. Try re-downloading the deb (if you got it via apt, clear it's cache first ("sudo apt-get clean")).


All times are GMT -5. The time now is 04:22 PM.