LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Wine programs crash, memory or driver? (https://www.linuxquestions.org/questions/linux-software-2/wine-programs-crash-memory-or-driver-707194/)

tparker 02-24-2009 01:53 PM

Wine programs crash, memory or driver?
 
I put a new video card in my system and programs through Wine are crashing now, sometimes with errors if ran from terminal, sometimes with no errors showing. So far I am having this happen to WoW, Ventrilo, and City of Heroes.

On the Wineappdb site I found a reference to a Wow crash problem (included here so I can ask about):

****Dalaran and/or other areas cause crashes

This is due to WoW running 32-bit (there is no 64-bit client) and trying to allocate more than roughly 4GB of memory for advanced textures. This is a bug in Wine, since wine, by default, reserves 4096MB (the maximum for 32bit systems) of virtual memory to mimic the win32 memory layout. WoW allocates progressively more memory for textures and this forces the display drivers (which are loaded in the same section of memory) to quit with an GL_OUT_OF_MEMORY error. <snip>
A possible workaround includes trying is to force Linux to use less memory than what you have, or to make it think it has less memory (eg, limit it to 3GB). The preferred way to do this is to add the mem=3072 (for 3GB) or mem=2048 (For 2GB) flag to your kernel boot parameters. ****


I did not think this was problem for a couple reasons,
1) I had been using the same computer and wine install with the same 5GB of ram and my old video card with no trouble
2)I do not get an "out of memory" error, instead I get:
*** glibc detected *** C:\Program Files\World of Warcraft\WoW.exe: corrupted double-linked list: 0x6902d3a8 ***
======= Backtrace: =========
/lib/libc.so.6[0x601e83a4]
/lib/libc.so.6[0x601ea123]
/lib/libc.so.6(cfree+0x96)[0x601ea356]
/usr/lib/nvidia/libGLcore.so.1[0x7cb2cd6a]

I have been trying to fix the crashes for a few days now and am not getting anywhere.

Is it possible that somehow my old video card did not trip the RAM allocation issue but my new one does? Old card was on the mainboard Nvidia geforce 6150se with a pittance of memory+shared memory. New card is Nvidia geforce 9800gt with 1gig ram.

Or could it be something in the driver?
if I run rpm -qa |grep nvidia I get:

xorg-x11-drv-nvidia-libs-180.29-1.fc10.i386
xorg-x11-drv-nvidia-libs-180.29-1.fc10.x86_64
kmod-nvidia-2.6.27.15-170.2.24.fc10.x86_64-180.29-1.fc10.x86_64
xorg-x11-drv-nvidia-180.29-1.fc10.x86_64
kmod-nvidia-2.6.27.12-170.2.5.fc10.x86_64-180.27-1.fc10.x86_64
kmod-nvidia-180.29-1.fc10.x86_64

Is it possible that i386 lib is throwing something off?

Any help is much appreciated and I will be happy to provide more info, just let me know what and how.

other info in case it's useful:
Fedora 10 AMD 64, installed form disk, fully updated
Wine version 1.1.14, installed through yum
nvidia driver installed/updated as part of Fedora system updates.
The only change to the system between stable and crashing was the video card and driver - everything else is the same.

tparker 02-24-2009 04:47 PM

Tried this regedit for opengl:GL_ARB_vertex_buffer_object from one of the WoW how tos.

It did not change anything. Still crashes the same as before, graphics go all wonky (big triangles of color like WoW used to do all the time if you weren't in opengl) right before the crash along with extremely slow frame rates (drop from 50+ fps down to <10, then graphics freak, then fps drops to 1-2, then crash.

Have been running Vent as well and it also seems fine at first and then degrades. After a while it only picks up some of your push to talk key pushes, then it stops picking up any but you can still hear other people, then you can't hear anyone. It stays open, still responds to button clicks, opens it's settings windows, etc, just does not send or receive voice. Still no errors in the terminal running it.

City of Heroes is the same, starts fine, goes downhill, crashes, no errors in the terminal running it.


All times are GMT -5. The time now is 06:36 PM.