-   Linux - Software (
-   -   Wine problem with emulators? (

r.daniels 12-01-2009 11:53 PM

Wine problem with emulators?
So I just installed Wine, and boy is it nifty!
But I'm having a problem.
The first program I attempted to use was RPG Maker 2003, it opened but I could see nothing. The window was there, and the toolbars and menus were there, but where the graphics should be...there was nothing. Then I tried to run Snes9x, a Super Nintendo Emulator, again I could see the menus and what not, but when I tried to run a game...I could see and hear NOTHING. Any ideas as to what my problem could be? I'm assuming it must be a graphical problem, not a wine problem, because the problem was the same in both VERY different programs, and besides not being able to SEE images in the program, the programs appeared to run fine.

evo2 12-02-2009 01:20 AM

Many programs have problems running under wine. Check out for details.

I don't know about "RPG Maker 2003" (never heard of it), but there are plenty of emulators running nativly on Linux, so you can avoid running wine. For example snes9x is even packaged for some Linux distributions. What distro are you using?


r.daniels 12-02-2009 11:17 AM

RPG Maker is, well, as the name implies, an RPG maker, heh. Anyway, I'm running Mint 7, if that helps.

i92guboj 12-02-2009 11:22 AM

First, you should always be checking if there's a native version of the program you want to run, or a viable alternative. In the case of snes9x you have both: the port itself and many alternatives like zsnes. Pick your choice. No need to use wine.

Second. If there's truly no other way around, go to the wine application database and check by yourself if there's a matching entry, in this case there are *lots*.

This will not only give you some idea about the current status of that program under wine, but you will also see how other users managed to get it working. Some programs will need some special setup to get them working.

evo2 12-02-2009 11:31 AM


Originally Posted by r.daniels (Post 3777204)
RPG Maker is, well, as the name implies, an RPG maker, heh.

I didn't ask what it was. Did you check as I suggested?


Anyway, I'm running Mint 7, if that helps.
Well, Mint is based on Ubuntu which is based on Debian which has snes9x packaged. I think you can join the dots.


All times are GMT -5. The time now is 08:01 PM.