LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-25-2014, 04:18 PM   #1
Hopsahejsa
LQ Newbie
 
Registered: Aug 2014
Distribution: CentOS 7
Posts: 21

Rep: Reputation: 0
Wine problem - cant install any app


Do you have any idea how to overcome this problem?

[admin@localhost ~]$ wine64 /home/admin/Downloads/anki-2.0.28.exe
fixme:service:scmdatabase_autostart_services Auto-start service L"MountMgr" failed to start: 2
wine: Bad EXE format for Z:\home\admin\Downloads\anki-2.0.28.exe.

Or If I try to run any win app through Wine file it returns only "Error"...

Thanks...
 
Old 08-25-2014, 04:34 PM   #2
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Why not try the file that's for a linux distro
http://ankisrs.net/download/mirror/
 
1 members found this post helpful.
Old 08-25-2014, 04:38 PM   #3
notKlaatu
Senior Member
 
Registered: Sep 2010
Location: Wellington, New Zealand
Distribution: Slackware, Fedora, NetBSD
Posts: 1,048

Rep: Reputation: 712Reputation: 712Reputation: 712Reputation: 712Reputation: 712Reputation: 712Reputation: 712
I'm no expert with WINE, but these are things I've run into when attempting to use it...

Does wine start at all? for instance, Notepad (I think it is) comes along as a demo app, and there are a few other wine apps that exist along with the install. Are you able to launch any of those? Usually upon first launch, there are some additional parameters that WINE has to set and download, so if you have never launched it and are now trying to install something, that could be part of the problem.

Have you tried installing other applications or is anki.blah.exe the first and only? perhaps look for a very small and simple app from sourceforge (maybe a text editor) and see if you have any luck with those. Could be as simple as actually having a corrupt .exe file.
 
1 members found this post helpful.
Old 08-25-2014, 06:05 PM   #4
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Ok I got it to work although pointless since it's available in linux.
But did it just to know howto use wine
Downloaded file it defaulted to /tmp (yours maybe different)
My wine version is compholio so change yours to your version
issued command
Quote:
/opt/wine-compholio/bin/winefile
wine opens
I click on Shell(which is host) to navigate to /tmp
double click in Anki .exe file
box opens prompting install
File installs & creates icon on Desktop

Last edited by EDDY1; 08-25-2014 at 06:06 PM.
 
2 members found this post helpful.
Old 08-26-2014, 03:34 AM   #5
Hopsahejsa
LQ Newbie
 
Registered: Aug 2014
Distribution: CentOS 7
Posts: 21

Original Poster
Rep: Reputation: 0
First thanks to all for your replies.
Just to clarify. Anki was the last app I tried to run so I pasted it here. I know Anki is for Linux Trying to install Remedy ticketing program.

To notKlaatu: Wine Wordpad, Wine file everything is working. It even downloaded some files upon starting.

To EDDY1: nice! Can I ask where did you get the wine-cornholio from? Do I need to get only that working or do I need normal wine as well?
I tried it from pipelight.net /repo for Fedora 20 and during installation (yum install wine-compholio) it asked for:

Error: Package: wine-1.7.24-10.1.x86_64 (home_DarkPlayer_Pipelight)
Requires: wine-mono
Error: Package: wine-core-1.7.24-10.1.i686 (home_DarkPlayer_Pipelight)
Requires: nss-mdns(x86-32)
Error: Package: wine-1.7.24-10.1.x86_64 (home_DarkPlayer_Pipelight)
Requires: mingw64-wine-gecko
Error: Package: wine-openal-1.7.24-10.1.i686 (home_DarkPlayer_Pipelight)
Requires: libopenal.so.1
Error: Package: wine-1.7.24-10.1.x86_64 (home_DarkPlayer_Pipelight)
Requires: mingw32-wine-gecko
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

The sam if I tried yum install wine. In my current repos only 1.7.22-1.el7 is available.

Sorry If this is stupid a question but I am kinda newcomer to Linux
 
Old 08-26-2014, 06:37 AM   #6
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
http://www.compholio.com/wine-compholio/
Netflix even works.

Last edited by EDDY1; 08-26-2014 at 06:41 AM.
 
1 members found this post helpful.
Old 08-26-2014, 09:26 AM   #7
Hopsahejsa
LQ Newbie
 
Registered: Aug 2014
Distribution: CentOS 7
Posts: 21

Original Poster
Rep: Reputation: 0
Tried on FC20 (1.7.24-1.fc20) and working like charm. Will need to struggle a little more to get it working in CentOS7.
Thanks
 
Old 08-26-2014, 11:34 AM   #8
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
It's all the same, you shouldn't have any problems.
If icon doesn't display as in gnome3, you can run
Quote:
wine "C:\Program Files\Anki\anki.exe"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wine problem, app does not starts. JonJoe Linux - Software 3 06-29-2011 09:44 AM
[SOLVED] Help with app in Wine! Advice Pro Linux - Software 3 02-27-2011 02:35 PM
Printing problem at Current Slack-Wine-Windows App. brodo Slackware 1 03-30-2009 09:40 AM
Requires ddeml.dll to install app using Wine jfallows Linux - Newbie 7 03-18-2008 11:48 PM
Can't install app's or updates.Ran 'sudo dpkg --configure -a' problem still exists vacuman Linux - Software 1 01-19-2007 01:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration