LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Wine not running games in full screen mode (https://www.linuxquestions.org/questions/linux-software-2/wine-not-running-games-in-full-screen-mode-81633/)

pyschomike15 08-13-2003 12:01 PM

Wine not running games in full screen mode
 
I'v been having this problem where Wine runs games in full screen mode but they are all haywire. The only way I can run then and see what im supposed to is make them run in a window. I do not know much about Wine and I want to know how to fix this problem.

Heres my config file:

WINE REGISTRY Version 2
[Drive A]
"Path" = "/mnt/fd0"
"Type" = "floppy"
"Label" = "Floppy"
"Filesystem" = "win95"
"Serial" = "87654321"
"Device" = "/dev/fd0"
[Drive C]
"Path" = "/home/mike/c"
"Type" = "hd"
"Label" = "MS-DOS"
"Filesystem" = "win95"
[Drive D]
"Path" = "/mnt/cdrom"
"Type" = "cdrom"
"Label" = "CD-Rom"
"Filesystem" = "win95"
"Device" = "/dev/hdc"
[Drive E]
"Path" = "/tmp"
"Type" = "hd"
"Label" = "Tmp Drive"
"Filesystem" = "win95"
[Drive F]
"Path" = "${HOME}"
"Type" = "network"
"Label" = "Home"
"Filesystem" = "win95"
[Drive Z]
"Path" = "/"
"Type" = "hd"
"Label" = "Root"
"Filesystem" = "win95"
[wine]
"Windows" = "c:\\windows"
"System" = "c:\\windows\\system"
"Temp" = "e:\\"
"Path" = "c:\\windows;c:\\windows\\system;e:\\;e:\\test;f:\\"
"Profile" = "c:\\windows\\Profiles\\Administrator"
"GraphicsDriver" = "x11drv"
"ShellLinker" = "wineshelllink"
# [wineconf]
[Version]
"Windows" = "win98"
"DOS" = "6.22"
[DllOverrides]
"oleaut32" = "builtin, native"
"ole32" = "builtin, native"
"commdlg" = "builtin, native"
"comdlg32" = "builtin, native"
"shell" = "builtin, native"
"shell32" = "builtin, native"
"shfolder" = "builtin, native"
"shlwapi" = "builtin, native"
"shdocvw" = "builtin, native"
"advapi32" = "builtin, native"
"msvcrt" = "native, builtin"
"mciavi.drv" = "native, builtin"
"mcianim.drv" = "native, builtin"
"*" = "builtin, native"
[x11drv]
"AllocSystemColors" = "100"
"PrivateColorMap" = "N"
"PerfectGraphics" = "N"
"Managed" = "Y"
"UseDGA" = "Y"
"UseXShm" = "Y"
"UseXVidMode" = "Y"
"UseTakeFocus" = "Y"
"DXGrab" = "N"
"DesktopDoubleBuffered" = "N"
[fonts]
"Resolution" = "96"
"Default" = "-adobe-helvetica-"
"DefaultFixed" = "fixed"
"DefaultSerif" = "-adobe-times-"
"DefaultSansSerif" = "-adobe-helvetica-"
[FontDirs]
[serialports]
"Com1" = "/dev/ttyS0"
"Com2" = "/dev/ttyS1"
"Com3" = "/dev/ttyS2"
"Com4" = "/dev/modem"
[parallelports]
"Lpt1" = "/dev/lp0"
[ppdev]
[spooler]
"FILE:" = "tmp.ps"
"LPT1:" = "|lpr"
"LPT2:" = "|gs -sDEVICE=bj200 -sOutputFile=/tmp/fred -q -"
"LPT3:" = "/dev/lp3"
[ports]
[Debug]
[registry]
"LoadGlobalRegistryFiles" = "Y"
"LoadHomeRegistryFiles" = "Y"
"LoadWindowsRegistryFiles" = "Y"
"WritetoHomeRegistryFiles" = "Y"
"SaveOnlyUpdatedKeys" = "Y"
[Tweak.Layout]
"WineLook" = "Win95"
[Clipboard]
"ClearAllSelections" = "0"
"PersistentSelection" = "1"
[afmdirs]
"1" = "/usr/share/ghostscript/fonts"
"2" = "/usr/share/a2ps/afm"
"3" = "/usr/share/enscript"
"4" = "/usr/X11R6/lib/X11/fonts/Type1"
[WinMM]
"Drivers" = "wineoss.drv" ; default for most common configurations
"WaveMapper" = "msacm.drv"
"MidiMapper" = "midimap.drv"
[dsound]
[Network]
[AppDefaults\\_INS0432._MP\\x11drv]
"Desktop" = "640x480"
[AppDefaults\\_INS0466._MP\\x11drv]
"Desktop" = "640x480"
[AppDefaults\\_INS0576._MP\\x11drv]
"Desktop" = "640x480"
[AppDefaults\\_INS5176._MP\\x11drv]
"Desktop" = "640x480"
[AppDefaults\\_INS5576._MP\\x11drv]
"Desktop" = "640x480"
# [/wineconf]

I hope you can help get this problem fixed right away. By the way I run Slackware 9.0 and have one of the latest NVIDIA drivers installed.

Thanks,
Mike

pyschomike15 08-13-2003 10:09 PM

Does anyone have any ideas. I really want to get this working before I goto this LAN party in a few days. If it doesnt work I might have to load Windows up again just to play a few games here and there.

teval 08-13-2003 11:49 PM

Add something like this to the end of your config file: (but before the #[/wineconf] line):

[AppDefaults\\(exact name of program)\\x11drv]
"Desktop"="(size)"

An example from my config file:

[AppDefaults\\War3.exe\\x11drv]
"Desktop"="1024x900"

Any size will do but.. try to use the nromal aspect ratio.. like 800x600

Good luck with the gaming


All times are GMT -5. The time now is 04:44 PM.