LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   wine: chdir to /tmp/.wine-tom/server-306-33fca : No such file or directory (https://www.linuxquestions.org/questions/linux-software-2/wine-chdir-to-tmp-wine-tom-server-306-33fca-no-such-file-or-directory-56748/)

Kinstonian 04-25-2003 12:21 PM

wine: chdir to /tmp/.wine-tom/server-306-33fca : No such file or directory
 
I got wine installed and tried testing it by running notepad and am getting this error. Anyone know how i can fix this?

[tom@localhost tom]# wine C:\\Windows\notepad.exe
wine: chdir to /tmp/.wine-tom/server-306-33fca : No such file or directory
[tom@localhost tom]#

looper 04-25-2003 07:28 PM

Hi, I got that disturbing error too when I compiled/intalled wine 20030408.

""After ~.wine/config creation"

Preparing to install default Wine registry entries...
Installing default Wine registry entries...

wine: chdir to /tmp/.wine-USER/server-343-150f46 : No such file or directory
Registry install failed."


So, I tried with this rpms

http://sourceforge.net/project/show...p?group_id=6241

You will also need codeweaver 's rpm. I hope they are useful for you
too.


q2

matt_w_lambert 04-25-2003 08:16 PM

the link above to source fourge doesn't work

is it for the wine.rpm

looper 04-25-2003 08:24 PM

This one should http://sourceforge.net/project/showf...?group_id=6241

IF it does not work go to freshmeat.net and do a search for wine

Streams 04-26-2003 02:59 AM

I get a very similar error, I used the rpm from the link above and when that didint work I used apt-get, yet I still get the error.

[root@Redhat_Linux_9 root]# wine
wine: chdir to /root/.wine/wineserver-Redhat_Linux_9.0 : Not a directory

Streams 04-26-2003 03:00 AM

btw: it is definitly a directory which i can view in konqueror.

Kinstonian 04-26-2003 03:00 AM

Yeah the one that gives me the error is wine-20030408-1rh8winehq.athlon.rpm from that site. I went to winehq's IRC channel and in the topic they said if your using RH9 and are getting that error you need to install a more recent version. To my knowledge that is the latest version though... I'll see if i can figure it out tommorrow...

Streams 04-26-2003 03:44 AM

thats the same package im using now.

wine-20030408-1rh8winehq.athlon.rpm

m00nd0g 04-26-2003 05:00 AM

Try deleting the directory wine is complaining about. This worked for me. It's annoying, though. Everytime you use wine, you should delete that dir.

I hope someone will come up with a better solution.

once 04-26-2003 12:57 PM

Same problem here with redhat 9

cannot delete a directory that is not

This must be a bigger problem as redhat did not release the winexx.rpm file with the distro.

Anybody got wine working with rh9?

once 04-26-2003 01:01 PM

Try this

export LD_ASSUME_KERNEL=2.2.5

worked for me

looper 04-26-2003 03:24 PM

Deleting or not deleting that directory, it will still appear that error. I tested it.

If you want to try it anyway, go to the c.l and type mc, get inside the USER folder and you will see it.

Try the rpms + codeweaver 's

Kinstonian 04-27-2003 04:07 PM

Quote:

Originally posted by once
Try this

export LD_ASSUME_KERNEL=2.2.5

worked for me

it works! Thanks man :)

mhearn 04-28-2003 10:30 AM

Recompile Wine, or get an RPM for your version of your distro.

This problem is due to the NPTL threading changes in glibc 2.3.x

joangon 04-30-2003 05:10 AM

Problem in Wine-20030408
 
Hi! Please Help!

I just installed wine-20030408 to my Red Hat 9 System, when I started running wine the ff. message appears:

wine: chdir to /tmp/ .wine-root/server-301-12689: No such file or directory

I really need to test some applications in wine ...
I will really appreciate your help ... Thanks in advance! ...


All times are GMT -5. The time now is 02:30 AM.