LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   wine broken and circular rpm's?? (https://www.linuxquestions.org/questions/linux-software-2/wine-broken-and-circular-rpms-197236/)

smiler 06-24-2004 01:12 PM

wine broken and circular rpm's??
 
Hello,
In Mandrake 10 wine is no way working.
In 9.2 it worked, so I tried to install that version.
Found out that rpm would install the new winelib from Mandrake 10.
It absolutely did not work.

Tried to install the old winelib first, but it wanted to also install the new wine.

So I had to disable all rpm sources except for at folder containing all wine rpm's from 13th of august 2003, then it installed and now it is working in Mandrake 10 official.

Do anybody have a new wine working under mandrake 10?
Is it normal that rpm's have circular dependencies like that?

LaqrHead 06-24-2004 04:14 PM

I cannot get the wine-20040615-mdk.i586.rpm to install and work either in Mandrake 10 either.

a3t 07-07-2004 01:57 AM

From wine site:
Quote:

Ivans comment that the Mandrake RPMs didn't work on Red Hat/Fedora surprised me, so after encountering a stuck Mandrake user for whom the RPMs weren't working either on IRC I decided to check them out.

It turns out the reason they don't work on Fedora is because they don't work at all - wine.inf is in /usr/share/doc/wine-20040615 which is wrong, it needs to be in /usr/share/wine. As this file is in the wrong place Wine refuses to start on a new users account.

Once I manually copied the file to the right place Wine worked just fine.


All times are GMT -5. The time now is 04:24 AM.