-   Linux - Software (
-   -   wine and serial port app (

bioe007 10-05-2007 01:21 PM

wine and serial port app
distro: ZW 4.6.1

I am running wine 0.9.46 with an application Dynamic-C ( a compiler for the rabbit line of embedded processors).

The program loads data to code space on the development board via a serial connection. I have linked: dosdevices/com1 -> /dev/ttyS0 and set up the system.reg entries.

the data seems to be getting sent out:

root[drive_c]# cat /proc/tty/driver/serial
serinfo:1.0 driver revision:
0: uart:16550A port:000003F8 irq:4 tx:7032 rx:6

but the information is not getting back to the program in 'wine space' ? I have tried running strace -o ~/dc.log wine <appname> and made some progress by renaming mixed case files to upper or lower case based on file not found errors.

here is the rest of what I've looked at, if anything else is of help please ask.
serial port info: (I have tried tweaking /dev/ttyS0 with the low_latency flag and numerous baud rates)

root[drive_c]# dmesg | grep tty
00:0c: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
root[drive_c]# ls -l /dev/ttyS0
lrwxrwxrwx 1 root root 5 2007-10-05 08:39 /dev/ttyS0 -> tts/0
root[drive_c]# ls -l /dev/tts/0
crwxrwx-w- 1 root tty 4, 64 2007-10-05 10:04 /dev/tts/0
root[drive_c]# setserial -abGv /dev/ttyS0
/dev/ttyS0 uart 16550A port 0x03f8 irq 4 baud_base 115200 spd_vhi skip_test low_latency

here are the relevant kernel modules:

root[drive_c]# lsmod | grep ser
serial_cs              21252  0
8250                  23828  4 serial_cs,8250_pnp
serial_core            20032  1 8250
pcmcia                37548  2 serial_cs,parport_cs

and interrupts:

root[drive_c]# cat /proc/interrupts
          CPU0      CPU1     
  0:    1855508          0  IO-APIC-edge      timer
  1:      7494          0  IO-APIC-edge      i8042
  3:          0          0  IO-APIC-edge      parport0
  4:      1321          0  IO-APIC-edge      serial


root[drive_c]# cat /proc/ioports | grep -2 3f8
03f6-03f6 : 0000:00:1f.2
  03f6-03f6 : libata
03f8-03ff : serial
04d0-04d1 : pnp 00:02
0910-091f : pnp 00:08

So I'm wondering if there is something in wine or a service that needs to be enabled to receive serial communication properly?

thanks for looking!

bioe007 10-16-2007 04:09 PM


I'm still looking for ideas... Anyone? Even generic nix/wine config tips may be useful, though I've tried to follow the docs for that stuff.


WoB 12-04-2008 06:22 AM

same problem
I have the same problem with wine and mono.
I have a sub to serial converter ttyUSB0.
I can send and receive data with gtkterm.
I can send data with mono and wine
But I cant receive data with mono and wine.
The program started in mono is written with Sharpdevelop/Monodevelop.
the program started in wine is written in delphi.
any idea ?

bioe007 12-05-2008 10:38 AM


Id strongly recommend startng your own thread vs jumping into one that is > 1yr old. You'll likely get much more help.

Alternatively, my final solution was to just use virtualbox, which works very well with usb peripherals, and use a usb->serial converter.


All times are GMT -5. The time now is 07:19 PM.