-   Linux - Software (
-   -   Windowmaker and nm-applet (NetworkManager) (

simopal6 11-10-2012 02:39 AM

Windowmaker and nm-applet (NetworkManager)
Hi everyone,

I'm having a problem trying to switch from KDE 4.8 (I think.. It's the default one which comes with Slackware 14) to Windowmaker, to see if my PC manages to work decently with 1 GB RAM.

Anyway, the first problem I encountered is network configuration. On KDE, I was using NetworkManager, and everything was ok. I remember telling NetwormManager not to encrypt the passwords (in fact, I can see that under .kde/share/apps/networkmanagement/secrets are a lot of files with my wireless PSKs inside); so, basically, it worked.

Then I decided to switch from KDE to Windowmaker. I installed the wmsystemtray tray application for nm-applet to find a place to stay, and ran nm-applet. As soon as I tried to connect to a wireless network, a popup message asked me to setup a "secret" for it, and since it wouldn't let me do without it, I created one settings an empty password; it complained about the password, but it was ok. Now, whenever I launch WindowMaker, the nm-applet is there, it is able to list the connections (not just the networks it finds by wifi-scanning, but it also shows me the networks I configured in KDE), but it always asks me for the network PSK, or WEP key, or whatever. After I give the password, it works, the connection is correctly set up. The problem is it won't save the password (it gives me an error when I try to save the password, saying something like "error updating network 'xxx', insufficient privileges"). And if I open the connection settings window from the tray icon, the password text field is always empty.

So... Any help? :) It would be nice if I could get NetworkManager to use the same passwords as in KDE... Or anyway, if not, any solution which would allow me to save it in any way would be happily accepted :) Thank you all!

markush 11-20-2012 02:22 PM


this is not explicitely an answer to your question. But if you connect always to the same network, why not use wpa_supplicant and make the appropriate entries in /etc/rc.d/inet1.conf instead of using NetworkManager?

I've used KDE some years ago, but then used fvwm for some years and have now Xmonad running. I have never used NetworkManager but do not feel I need it. Also with different networks I have no problems to connect with wpa_supplicant only.


All times are GMT -5. The time now is 04:28 AM.