-   Linux - Software (
-   -   Win2K/RH7.1 Dual, RH won't boot from boot disk after install (

marktaff 08-24-2001 06:25 AM

Win2K/RH7.1 Dual, RH won't boot from boot disk after install

I can't get RH to boot from the boot disk I created during the install. The install appeared to go perfectly. /boot is below 1024, and lilo was not written to the MBR. I get the error message: 'Boot Failed: please change disks and press a key to contunue.' I installed win2k first, then I chose a custom install and used disk druid to make my linux partitions.

System specs: AMD K62/400Mhz, 1-40GB hd, one 7GB Fat32 partition for win2k, 30MB partition for /boot, 775MB swap, 1GB /var, 1GB /, 3.2GB /usr, and 3.2GB /home, remaining disk space unpartitioned (will use for other win2k partitions later). 256MB RAM

I have tried boot paramters of /dev/hdaX , where x is between 0-15 (I have tried them all). It defaults to booting from /dev/hda8

Win2k boots just fine. I know about peeling the first 512k from /boot and modifying boot.ini to have ntldr boot linux, but I can't get into linux to make the file (bootsect.lnx).

I'm new at this, and I've tried everything I could think of or otherwise glean from other posting on the Internet. Any help would be greatly appreciated.



P.S. My email is of course down right now, so if you want to e-mail me on this matter, please send it to

gurusmaran 08-24-2001 06:53 AM

here's something for you...
hi mark,

here's a solution to your problem. i got it off some site. i copied and pasted it for your convenience.


To work around this problem, do the following:
Boot off the CD as usual and select options until you reach the screen that asks you to choose between DiskDruid and fdisk partitioning.
Select partitioning using fdisk
Select the hard disk to partition
When fdisk starts, press "p" and [enter], and verify that you have an extended partition defined. If you do, skip the next step
If you do not see an extended partition, create one as follows:
Type "n" and press [enter]
Select "e" and press [enter]
Choose "4" for the extended partition number
Press [enter] to accept all defaults
When you return back to the command prompt, type "p" and verify that you now have an extended partition
Now press "n" and select "l" (small ell) and [enter]
Press [enter] to accept the default start cylinder
Enter "+50M" to specify the size of 50 MB
Type "p" and [enter] to verify that you now have a Linux partition, and that the partition number is >=5 (which means that it is logical).
Type "w" and [enter] to write the config to disk and exit
When you are back in the installer, press the [back] button to get back to the DiskDruid/fdisk choice screen
Select DiskDruid, and press [next]
In DiskDruid, double-click the nameless 50 MB partition you see there and call it "/boot"
Create swap, root and other partitions as required
verify that none of the partitions are showing up in red colour and that they all have a value in the "Actual Allocation" column.
Proceed to the next screen by pressing [next]. At this point, you will receive a warning about /boot being beyond 1024 cylinders, just click [OK]
You have put the partition containing the kernel above the 1024
cylinder limit. It appears thet this system's BIOS supports booting
from above this limit

If the error message indicates that your system's BIOS does not support booting from above the 1024 limit, this method will not work. You will have to resize partitions and make sure that /boot is within the first 1024 cylinders. Placing /boot within the first 6.4GB is a safe bet.
In any case, make a boot-disk on a clean floppy which has *no* bad sectors. Loadlin is also a clean solution for use in case LILO fails.
Proceed with the installation as usual.


marktaff 08-24-2001 07:17 AM

do I need two extended partitions?
fdisk says I have an extended partition from 1022 to 5169. all my linux partitions are above 1022, except for /boot, which is from 1017 to 1021. My win2k partition is from 1 to 1016.

marktaff 08-24-2001 02:51 PM

still not working...
I followed the advice by gurusmaran and reinstalled evrything, and it still doesn't work. Any ideas? Thanks.


marktaff 08-24-2001 06:29 PM

It's working
I have it dual booting properly now, but it still won't boot into Linux from a floppy. I'll have to worry about that later. Thanks for all your help.


All times are GMT -5. The time now is 09:02 PM.