-   Linux - Software (
-   -   win xp home edition and samba home shares (

scheidel21 02-25-2003 04:17 PM

win xp home edition and samba home shares
I have a samba server setup on my home lan running a debian 3.0 server 2.2 kernal samba 2.2.3a-12 I have 2 winXP homedition PCs connected I can see all the computers in the workgroup, I can access shares on the win machines from linux, and I can access all shares on the samba server except for the homes share, even my own , I have security set to user and I logo on fine initially with any user name I have listed except when I attempt to access the homes share, or my own shares folder it requests I re-enter username password, I do so and it spits back at me with my computer name and the username I entered without allowing me access to those folders.

\\Alex\scheidel21 is what it spits back in username box...the valid smbpasswd username is scheidel21....the username alone allows me access to printers, other shares, just not home share any ideas?

ranger_nemo 02-25-2003 10:47 PM

Might be a typo in your [homes] section of your samba.conf . Post it here so we can look.

scheidel21 02-25-2003 11:16 PM

This is the smb.conf file it seems ok.

passwd program = /usr/bin/passwd %u
domain master = yes
printing = bsd
dns proxy = yes
syslog only = no
name resolve order = lmhosts host wins bcast
encrypt passwords = yes
short preserve case = yes
wins support = true
printcap name = /etc/printcap
invalid users = root
max log size = 1000
announce as = NT Server
passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n
prefered master = yes
preserve case = yes
security = user
unix password sync = true
local master = yes
workgroup = MSHOME
server string = %h server (Samba %v)
syslog = 4;
netbios name = debian
load printers = yes
os level = 65
public = yes

writable = yes
comment = Home Directories
create mask = 0700
only user = yes
directory mask = 0700
browseable = yes

path = /tmp
browseable = yes
writeable = yes

path = /usr/share/icecast/static/
browseable = yes
writeable = yes

comment = All Printers
browseable = no
path = /tmp
printable = yes
public = no
writable = no
create mode = 0700

I'm kinda dumbfounded don't know what to do. thanks guys

ranger_nemo 02-26-2003 05:25 PM

I have...

  comment = Home Directories
  browseable = no
  writable = yes
  valid users = %S
  create mode = 0664
  directory mode = 0775

ranger_nemo 02-26-2003 05:29 PM

From the smb.conf man page...

only user (S)
              This  is a boolean option that controls whether connections with
              usernames not in the user list will be allowed. By default  this
              option  is disabled so that a client can supply a username to be
              used by the server.  Enabling  this  parameter  will  force  the
              server  to  only  user the login names from the user list and is
              only really useful in shave level security.

              Note that this also means Samba wonít try  to  deduce  usernames
              from the service name. This can be annoying for the [homes] sec‐
              tion. To get around this you could use user  =  %S  which  means
              your  user  list  will  be just the service name, which for home
              directories is the name of the user.

scheidel21 02-26-2003 11:26 PM

thanks man it worked, worked like a dream

chk 09-19-2003 03:40 AM

Same Configuration => Same Error, even after hints
Hi all,
In principle I have the same configuration as described here: WIN XP Home (German SP1, Workgroup ART ComputerName Greifensee) and Linux (Debian Kernel 2.4.20) Samba 2.2.3a-6 for Debian. I can ssh from winxp using PUTTY to linux. I can even use samba from a WIN2kPro PC but not from my WINXPHOME.

I used the conf file published here but changed : workgroup = ART and uncommented icecast section.

Trying to log on password dialog opens and I give details for my home account on this machine and the dialog comes back with \\GREIFENSEE\kaas the log files of samba in /var/log/samba/ say : passdb/pdb_smdpasswd.c:pdb_getsampwnam(1367) unable to open passdb database ?

Any hint would help.

scheidel21 09-26-2003 05:10 AM

logon problem
sounds as though it is unable to acccess your database of passwords.....I don't know I wonder if it may be somethings to do with service pack 1 I have heard of it causing problems similar to this with Samba, I suggest if you can try it with an XP machine without SP1 and see what that gets you, good luck sir


khan_ihsanullah 10-09-2008 12:47 AM

samba configuration VISTA and LINUx
I have vista home edition in my laptop.
I have to connect it with LINUX server.
I have used samba 3.0.x for that purpose.
VISTA does not support secpol.msc then i changed my registry value of LSA Lmcompitability Dword value to 1. But VISTA is not connecting with server. One thing that xp home edition is working perfectly.Please answer as quickly as possible.

All times are GMT -5. The time now is 04:24 AM.