LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-29-2003, 03:01 PM   #1
SnowSurfAir
Member
 
Registered: Mar 2003
Distribution: Redhat 9
Posts: 459

Rep: Reputation: 30
Will someone help me?


I have a flat panel monitor and a vid card that has tv out I've installed the NVIDIA driver but when I hook up the tv out cord and reboot the x server wont boot unless I unplug the tv herre is the relevent part of my XF86Config file:
Code:
Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "SDM-S71"
	DisplaySize  340	270
	HorizSync    28.0 - 65.0
	VertRefresh  48.0 - 65.0
	Option	    "dpms"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
	VendorName  "NVidia"
        Option "Twin View" "true"
        Option "SecondMonitorHorizSync" "30-50"
        Option "SecondMonitorVertRefresh" "60"
        Option "MetaModes" "1024x768,1024x786; 1024x786,1024x786"
        Option "TVStandard" "NTSC-M"
        Option "ConnectedMonitor" "DFP, TV"
        Option "TVOutFormat" "SVIDEO"
	BoardName   "NVIDIA GeForce 4 MX (generic)"
	VideoRam    65536
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Depth     24
		Modes    "1024x768" "800x600" "640x480"
	EndSubSection
EndSection
What do I need to change or add to make it work??
 
Old 07-29-2003, 03:24 PM   #2
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
I don't see anything wrong, but here is mine:

Code:
# XFree87 4 configuration created by redhat-config-xfree86
                                                                                
Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "DevInputMice" "AlwaysCore"
EndSection
                                                                                
Section "Files"
                                                                                
# RgbPath is the location of the RGB database.  Note, this is the name of the
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        FontPath     "unix/:7100"
EndSection
                                                                                
Section "Module"
                                                                                
        Load  "dbe"
        Load  "extmod"
        Load  "fbdevhw"
        Load  "glx"
        Load  "record"
        Load  "freetype"
        Load  "type1"
#       Load  "dri"
EndSection
                                                                                
Section "InputDevice"
                                                                                
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#       Option  "Xleds"         "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#       Option  "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#       Option  "XkbModel"      "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#       Option  "XkbModel"      "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#       Option  "XkbLayout"     "de"
# or:
#       Option  "XkbLayout"     "de"
#       Option  "XkbVariant"    "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#       Option  "XkbOptions"    "ctrl:swapcaps"
# Or if you just want both to be control, use:
#       Option  "XkbOptions"    "ctrl:nocaps"
#
        Identifier  "Keyboard0"
        Driver      "keyboard"
        Option      "XkbRules" "xfree86"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "se"
EndSection
                                                                                
Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
                                                                                
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/psaux"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "no"
EndSection
                                                                                
Section "InputDevice"
                                                                                
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
        Identifier  "DevInputMice"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "no"
EndSection
                                                                                
Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Samsung Samtron 75(M)E (Plus)"
                                                                                
        DisplaySize  320        240
        HorizSync    30.0 - 70.0
        VertRefresh  50.0 - 160.0
        Option      "dpms"
EndSection
                                                                                
Section "Device"
        Identifier  "Videocard0"
        Driver      "nvidia"
        VendorName  "Videocard vendor"
        BoardName   "NVIDIA GeForce 4 (generic)"
        Option      "Rotate" "off"
        Option      "TwinView" "true"
        Option      "SecondMonitorHorizSync" "30-50"
        Option      "SecondMonitorVertRefresh" "60"
        Option      "MetaModes" "1024x768,1024x768;800x600,800x600;640x480,640x480"
        Option      "TVStandard" "Pal-B"
        Option      "ConnectedMonitor" "CRT,TV"
        Option      "TwinViewOrientation" "Clone"
        Option      "TVOutFormat" "SVIDEO"
EndSection
                                                                                
           Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Depth     24
                Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600"
"640x480"
        EndSubSection
EndSection
                                                                                
Section "DRI"
        Group        0
        Mode         0666
EndSection
 
Old 07-29-2003, 03:58 PM   #3
SnowSurfAir
Member
 
Registered: Mar 2003
Distribution: Redhat 9
Posts: 459

Original Poster
Rep: Reputation: 30
well I got it on the screen but it (1) is in black and white and (2) the tv screen just keeps like moving down over and over again what should I do
 
Old 07-29-2003, 04:14 PM   #4
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Ok, let's see.... It looks like it's either a color system problem or a vsync problem....
Anyway, in text mode, it should be as you mentioned above, but when you startx, it should be fine.

Try changing

Option "TVStandard" "Pal-B"

To your color system type... usually USA uses NTSC and Japan too, Europe and Latin America sticks with PAL-something (pal-g. pal-m)
 
Old 07-29-2003, 04:30 PM   #5
SnowSurfAir
Member
 
Registered: Mar 2003
Distribution: Redhat 9
Posts: 459

Original Poster
Rep: Reputation: 30
well It was that and I needed to change it from svideo to COmposite. thanks but I have trouble readin stuff on the tv how can I make it clearer(if I can)?
 
Old 07-29-2003, 04:34 PM   #6
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Hmmm, I don't know how bad it is for you, but as far as I know, the TV is much lower resolution then monitors, so you most likely won't be able to read or surf the web with as clean as the monitor. But to watch Movies/DVD's or play games it's enough.... . Unless it's just too bad then we have a problem
 
Old 07-29-2003, 04:36 PM   #7
SnowSurfAir
Member
 
Registered: Mar 2003
Distribution: Redhat 9
Posts: 459

Original Poster
Rep: Reputation: 30
ok thanks
 
Old 07-29-2003, 04:37 PM   #8
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
no problems, you are welcome
 
Old 07-29-2003, 05:23 PM   #9
daborg69
LQ Newbie
 
Registered: Jul 2003
Posts: 2

Rep: Reputation: 0
SnowSurf,

Sounds like you have it working. I have been messing with mine off and on for awhile now. I can get the TV or the Monitor to work, but not both at same time. I noticed you said you had an ASUS video card. What Model? and could you post your XF86Config-4 file? I also noticed you said yours works outside of X? I only get the TV when in X.

Thanks for any hints you can provide.
 
Old 07-29-2003, 05:44 PM   #10
SnowSurfAir
Member
 
Registered: Mar 2003
Distribution: Redhat 9
Posts: 459

Original Poster
Rep: Reputation: 30
yeah it is a V9180 Magic and my XF86Config file doesnt have a -4 after it herre it is:
Code:
# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database.  Note, this is the name of the 
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
	RgbPath      "/usr/X11R6/lib/X11/rgb"
	FontPath     "unix/:7100"
EndSection

Section "Module"
	Load  "dbe"
	Load  "extmod"
	Load  "fbdehw"
	Load  "glx"
	Load  "record"
	Load  "freetype"
	Load  "type1"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#	Option	"Xleds"		"1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#	Option	"XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#	Option	"XkbModel"	"pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#	Option	"XkbModel"	"microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#	Option	"XkbLayout"	"de"
# or:
#	Option	"XkbLayout"	"de"
#	Option	"XkbVariant"	"nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#	Option	"XkbOptions"	"ctrl:swapcaps"
# Or if you just want both to be control, use:
#	Option	"XkbOptions"	"ctrl:nocaps"
#
	Identifier  "Keyboard0"
	Driver      "keyboard"
	Option	    "XkbRules" "xfree86"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "no"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
	Identifier  "DevInputMice"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "no"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "SDM-S71"
	DisplaySize  340	270
	HorizSync    28.0 - 65.0
	VertRefresh  48.0 - 65.0
	Option	    "dpms"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
	VendorName  "NVidia"
	BoardName   "NVIDIA GeForce 4 MX (generic)"
	VideoRam    65536
        Option      "TwinView" "true"
        Option      "SecondMonitorHorizSync" "30-50"
        Option      "SecondMonitorVertRefresh" "60"
        Option      "MetaModes" "1024x768,1024x768;800x600,800x600;640x480,640x480"
        Option      "TVStandard" "NTSC-M"
        Option      "ConnectedMonitor" "DFP,TV"
        Option      "TwinViewOrientation" "Clone"
        Option      "TVOutFormat" "Composite"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Depth     24
		Modes    "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "DRI"
	Group        0
	Mode         0666
EndSection
I havent tried it outta X I meant when bootin, and do u have it set for twin View?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration