-   Linux - Software (
-   -   Why won't VMWare Player run on Fedora 8 (

slsscoot 02-01-2008 08:40 PM

Why won't VMWare Player run on Fedora 8
I'm new to linux and am trying to get the VMWare Player installed so I can have a virtual WXP machine for certain apps.

I have kernel- installed and I downloaded the VMware-player-2.0.2-59824.i386.rpm and installed it per the directions.

rpm -Uhv VMware-player-2.0.2-59824.i386.rpm

followed the prompts then ran

When it got to the end, here is what I had in the terminal:

Trying to find a suitable vmmon module for your running kernel.

None of the pre-built vmmon modules for VMware Player is suitable for your running kernel. Do you want this program to try to build the vmmon module for your system (you need to have a C compiler installed on your system)? [yes]

Setup is unable to find the "make" program on your machine. Please make sure it is installed. Do you want to specify the location of this program by hand?

I have no idea how to correct this. There was mention about:
-the location of the C headers
-the kernel-source matching

Any help is appreciated. I'm making the big leap because it's the right thing to do, however, I have some things that will continue to linger while I find replacements.


waelaltaqi 02-01-2008 08:50 PM

if i were you i would stay away from the binary package. Go and download the player from VMware website and install according to the documentation. If you couldn't run the install script for any reasons then post error messages and we will help you out.

Lenard 02-01-2008 08:51 PM

Install the gcc and kernel-devel rpm package if needed;

check: rpm -qa gcc kernel-devel
yum install kernel-devel

slsscoot 02-01-2008 09:02 PM

[scooter@localhost ~]$ rpm -qa gcc kernel-devel

I did the yum install kernel-devel

then tried again....same results exactly.

am I doing something wrong?

ps. The VMware-player-2.0.2-59824.i386.rpm was downloaded from and I followed the instructions posted to the site.

slsscoot 02-01-2008 09:03 PM

forgot to post the info after the kernel-devel install

[scooter@localhost ~]$ rpm -qa gcc kernel-devel

Lenard 02-02-2008 07:14 AM

With the Red Hat family one needs to specify the location, the location something like;


Also waelaltaqi is right in his/her suggestion about not using the VMware-player rpm package.

slsscoot 02-06-2008 08:32 PM


I downloaded the .tar.gz file and while following the instructions, I get to the same place where it asks me for the location of the "make" program on my computer.

Not understanding exactly what I'm looking for, I followed the suggestions listed and put in the following path:

Same message comes up

In the /usr/src/kernels/ directory, there is a "Makefile" so I tried that luck.

Not sure what I'm doing wrong or where to get a "make" program to complete this.


Lenard 02-06-2008 09:29 PM

Hmmm.........please check; rpm -qa --qf="%{n}-%{v}-%{r}.%{arch}\n" 'gcc*' 'kernel*' | sort
Sample output:

Notice how things match up by version numbers.

slsscoot 02-07-2008 09:27 PM

Here is my output

[root@localhost ~]# rpm -qa --qf="%{n}-%{v}-%{r}.%{arch}\n" 'gcc*' 'kernel*' | sort
[root@localhost ~]#

Lenard 02-07-2008 10:59 PM

Make sure you are running the 2.6.23-14-115 kernel; uname -a
If need be reboot the system and select this kernel, you might have to press any key when the grub splash screen is displayed in order to do this.

antus 02-13-2008 11:50 PM


antus 02-13-2008 11:52 PM

You havnt installed the development packages, which means you are probably missing a whole lot of tools. Its a very good idea to find the development packages when installing fedora/rhel/centos and select them during installation every time. Theres a good chance you'll need them for something during the installations life.

To get make do:

yum install make

Next up there will probably be another tool required. Guess the package name, or use "yum search somefile" which may help. After a few of these you might be OK.

Im here fighting another problem with vmware full. Not sure if your going to hit it too after you build the kernel modules ok.

[ant@ant ~]$ vmware
process 20726: Attempt to remove filter function 0x3f96a05020 user data 0x94cc40, but no such filter has been added
D-Bus not built with -rdynamic so unable to print a backtrace

Maybe fedora 8 is still too new?

PS Im using an rpm version, and have been since pre fedora core 6. I dont think there are any specific probs with rpm versions vs tarballs.

[ant@ant ~]$ rpm -qa | grep -i vmware

slsscoot 02-15-2008 11:37 PM

I seem to be getting further after doing

yum install make
and then
yum install gcc

But here is what I'm getting stuck on now:
What is the location of the directory of C header files that match your running
kernel? [/usr/src/linux/include]

Not sure what that is.


antus 02-16-2008 02:48 AM

yum install kernel-devel

PS The problem i mentioned above went away with the current fedora 8 kernel (, so appears to be a bug in Vmware is now running fine on my machine.

slsscoot 02-17-2008 07:48 AM

that did it!!!

It's finally installed and running with the new kernel.


thanks to all for the needed guidance for this newbie.

SLSScoot (Scooter)

All times are GMT -5. The time now is 12:45 AM.