LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-04-2005, 10:19 PM   #1
bvav22
Member
 
Registered: Apr 2005
Distribution: Slackware 10.1
Posts: 43

Rep: Reputation: 15
why the heck.....


ok, i had JUST gotten my system correctly configured, and had all my drivers working. i had 3d for my drivers by doing these steps i found on driver heaven, i have a radeon 9700 pro, on kernel 2.6.11.7, slack 10.1 . now as i said i had everything working until i shutdown incorrectly and at the time i had an ext2 partition so my filesystem fucked up. so now install everything on an ext3 partition so i dont have that problem. i installed the kerenel the same way. the only thing i did different this time was i didnt instlal and software i use yet. i want 3d first. so now when i go to run make_install.sh to install the fglrx modules. i get this now....


root@brian:/lib/modules/fglrx# ./make_install.sh
- creating symlink
- recreating module dependency list
- trying a sample load of the kernel module
FATAL: Error inserting fglrx (/lib/modules/2.6.11.7/kernel/drivers/char/drm/fglrx.ko): Operation not permitted
failed.


please someone help me out. it worked last time, why wont it work this time?!?
 
Old 05-04-2005, 10:46 PM   #2
bvav22
Member
 
Registered: Apr 2005
Distribution: Slackware 10.1
Posts: 43

Original Poster
Rep: Reputation: 15
any one have anything? i need 3d so bad
 
Old 05-05-2005, 10:51 PM   #3
bvav22
Member
 
Registered: Apr 2005
Distribution: Slackware 10.1
Posts: 43

Original Poster
Rep: Reputation: 15
i have come to the conclusion that is has to be the way i configured my kernel, does anyone have any idea wat i could have compiled wrong, or not compiled at all to do this? like i said it worked last time
 
Old 05-08-2005, 12:46 AM   #4
bvav22
Member
 
Registered: Apr 2005
Distribution: Slackware 10.1
Posts: 43

Original Poster
Rep: Reputation: 15
no one has any idea?
 
Old 05-10-2005, 09:42 PM   #5
bvav22
Member
 
Registered: Apr 2005
Distribution: Slackware 10.1
Posts: 43

Original Poster
Rep: Reputation: 15
everyone is so helpful here
 
Old 05-10-2005, 09:59 PM   #6
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 914Reputation: 914Reputation: 914Reputation: 914Reputation: 914Reputation: 914Reputation: 914Reputation: 914
look ... no need to be bitter. Someone is always going
to be the first one to encounter a specific problem. Others
won't be able to reproduce it, thus shooting random rounds
of thought would be as frustrating for them as it would be
for you. Just live with it. Try to re-work what you've done,
maybe ...

Have you still got the .config file from the working version?
No? That'll teach you to preserve working config files.


Cheers,
Tink
 
Old 05-10-2005, 10:07 PM   #7
mcleodnine
Senior Member
 
Registered: May 2001
Location: Left Coast - Canada
Distribution: s l a c k w a r e
Posts: 2,731

Rep: Reputation: 45
Quote:
FATAL: Error inserting fglrx (/lib/modules/2.6.11.7/kernel/drivers/char/drm/fglrx.ko): Operation not


is that the correct path for the modules?
 
Old 05-11-2005, 08:48 PM   #8
bvav22
Member
 
Registered: Apr 2005
Distribution: Slackware 10.1
Posts: 43

Original Poster
Rep: Reputation: 15
yes it is the correct path, it work last time, and idk wats wrong this time....


sry to sound bitter i just felt ignored
 
Old 05-11-2005, 09:12 PM   #9
bvav22
Member
 
Registered: Apr 2005
Distribution: Slackware 10.1
Posts: 43

Original Poster
Rep: Reputation: 15
ok i decided to think windows for a second, now if in windows and i was told permission denied i would think that the hd permissions are screwed, so i looked at my permission settings for my hda
they are as follows

Owner: Can view content
Group: Forbidden
Other: Forbidden

and when i try to change them i get, Changing the attributes of files is not supported with protocol devices.
 
Old 05-11-2005, 09:28 PM   #10
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 914Reputation: 914Reputation: 914Reputation: 914Reputation: 914Reputation: 914Reputation: 914Reputation: 914
What fs-type does the /lib directory reside on, what are the
mount options, what are the perms on ALL of the parent
directories?
 
Old 05-11-2005, 09:37 PM   #11
bvav22
Member
 
Registered: Apr 2005
Distribution: Slackware 10.1
Posts: 43

Original Poster
Rep: Reputation: 15
the fs is ext3, what do you mean by mount options?, and the perms that i listed came from when i right click on hda2 in my devices folder
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
What the heck .. Xvium Linux - Hardware 2 04-11-2005 01:51 AM
What the heck??? scrible Linux - Newbie 10 01-03-2005 07:38 PM
What the heck is THIS ?? Post Modern Linux - Security 5 10-14-2004 04:53 PM
What in the heck is this??? slackMeUp Slackware 2 04-05-2004 05:26 PM
What the heck? Diablotrickster Linux - Networking 7 08-30-2003 10:27 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration