LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-15-2004, 10:40 PM   #1
enigma Z
Member
 
Registered: Sep 2003
Location: The edge of the world, peering down into the dark abyss
Distribution: Gentoo 2004.2
Posts: 224

Rep: Reputation: 30
Why isn't Gnome working for my regular user?


I've just installed gnome, but halfway through the compile, I had to stop and shut my computer down. When I logged back in, Gnome was set as the default window manager, so I started a login into gnome by accident, and I got an error message about not being able to connect to the system service manager.

I got past that and exited gnome and finished installing. But now my desktop is empty, and when it boots up it only loads the panel and the system services daemon. So, thinking that it was just because of the previous login, I copied root's .gnome2/session file, and replaced all refernces to root's home directory with enigma's (my regular user). Now, it balks on starting the "metacity window manager" and it will not complete loading.

What did I do?? And is there any way to reset it to the "default" settings where it loads metacity, the panel, etc?

If you need output from any commands, please ask ^_^
 
Old 09-15-2004, 11:16 PM   #2
CroMagnon
Member
 
Registered: Sep 2004
Location: New Zealand
Distribution: Debian
Posts: 900

Rep: Reputation: 33
It got interrupted halfway through compiling??
I would make sure the compile and install completed before looking to fix anything else, and then I think I would just delete your regular user's entire .gnome directory and let it create a nice new one.
 
Old 09-15-2004, 11:25 PM   #3
enigma Z
Member
 
Registered: Sep 2003
Location: The edge of the world, peering down into the dark abyss
Distribution: Gentoo 2004.2
Posts: 224

Original Poster
Rep: Reputation: 30
Thanks for your help, but I think I just fixed it... before, it wasn't loading the desktop, so I copied the root session file like I said, but I needed it to point to the old metacity *.mc file in the session. Now it is running good! Thanks!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Adding a regular user to GNOME and fluxbox kushalkoolwal Debian 8 11-07-2005 11:59 PM
Wine as regular user scouture Linux - Software 2 03-11-2005 09:49 PM
Can't Login As Regular User After Trying... drdroid Linux - General 8 02-08-2004 11:30 AM
How do I login as a regular user? hitbob Linux - Newbie 2 10-04-2003 05:14 AM
Modem and MIDI not working as regular user samB Linux - Hardware 0 07-05-2003 03:54 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration