LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-05-2013, 09:47 AM   #1
littlebigman
Member
 
Registered: Aug 2008
Posts: 553

Rep: Reputation: 33
Question Why is this process only listening on TCP6?


Hello

I just installed the Privoxy web filter through apt-get on an ARM appliance, and noticed it's only listening on TCP6 instead of TCP (+ TCP6):

Code:
# netstat -tunlp | grep privoxy
tcp6       0      0 ::1:8118                :::*                    LISTEN      18276/privoxy

# grep listen-address /etc/privoxy/config
listen-address  localhost:8118
The startup script doesn't seem to include a setting that would explain this behavior:
Code:
/etc/init.d/privoxy
# Function that starts the daemon/service
#
do_start()
{
        # Return
        #   0 if daemon has been started
        #   1 if daemon was already running
        #   2 if daemon could not be started
        start-stop-daemon --start --quiet --pidfile $PIDFILE --exec $DAEMON --test > /dev/null \
                || return 1
        start-stop-daemon --start --quiet --pidfile $PIDFILE --exec $DAEMON -- \
                $DAEMON_ARGS \
                || return 2
        # Add code here, if necessary, that waits for the process to be ready
        # to handle requests from services started subsequently which depend
        # on this one.  As a last resort, sleep for some time.
}
Any idea what I could to do have it listen on TCP?

Thank you.
 
Old 12-05-2013, 10:19 PM   #2
Ser Olmy
Senior Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 2,680

Rep: Reputation: Disabled
Have you tried specifying the IPv4 localhost address (127.0.0.1) in the config file instead of the name "localhost"?

Does the name "localhost" resolve to both 127.0.0.1 and ::1 on your system? (Check the /etc/hosts file; try both ping localhost and ping6 localhost).
 
Old 12-07-2013, 05:31 PM   #3
littlebigman
Member
 
Registered: Aug 2008
Posts: 553

Original Poster
Rep: Reputation: 33
Thanks Ser, editing /etc/hosts and restarting Privoxy solved the problem

Code:
...
# Commented those lines
#::1     localhost ip6-localhost ip6-loopback
#ff02::1 ip6-allnodes
#ff02::2 ip6-allrouters
 
Old 12-07-2013, 07:59 PM   #4
Ser Olmy
Senior Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 2,680

Rep: Reputation: Disabled
Instead of comenting out those lines, adding
Code:
127.0.0.1     localhost
on a separate line would probably have done the trick as well.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to find what process is listening on a certain port? laredotornado Linux - General 15 11-28-2017 01:26 PM
If I have a nc process running and listening on a port... trist007 Linux - Newbie 3 02-09-2010 02:35 AM
Bind - Address already in use - How to get process listening on the port in C? hgrover Linux - Networking 0 03-21-2008 02:52 AM
Running a chat listening process infinitly. j0hn_galt Programming 5 12-06-2005 10:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration