LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-18-2013, 01:25 AM   #1
ajayyadavmca
LQ Newbie
 
Registered: Dec 2006
Posts: 28

Rep: Reputation: 0
why grub loader fails in my case


Hi,

we have use case, where we have to backup all partition and restore them back.

so for boot partition we copy files and create tar backup, for rest of them we take lv_snapshots as they are logical volumes.

now after restoring boot partion when we boot OS we get on grub error.

we can fix it by reinstalling grub by grub-install, but wanted to know reason why grub fails to load as we have not changed harddisk or OS then why grub loader is corrupetd or overwritten or deleted?
what is exact reason.
please let me know.. thank in advance

OS: Cent OS 6.4
 
Old 11-18-2013, 02:08 AM   #2
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 16,963

Rep: Reputation: 2564Reputation: 2564Reputation: 2564Reputation: 2564Reputation: 2564Reputation: 2564Reputation: 2564Reputation: 2564Reputation: 2564Reputation: 2564Reputation: 2564
Quote:
Originally Posted by ajayyadavmca View Post
why grub loader is corrupetd or overwritten or deleted?
what is exact reason.
None of the above.
The backup and restore has moved the grub files - the grub-install should be a part of any sane recovery plan.

Were you to be using grub (classic) your procedure [ws]ould have worked as you expected.
 
Old 11-18-2013, 03:45 AM   #3
ajayyadavmca
LQ Newbie
 
Registered: Dec 2006
Posts: 28

Original Poster
Rep: Reputation: 0
thanks for reply

thanks for reply,

i accept that grub-install should be part of my plan. and yes it is part of my plan and it works fine too. but as i said i wanted to know the root cause of issue.

when i have grub-install it work fine else i get error. this means it has issue.. let me know if my understanding is correct.

** yes we have verified back is fine.

Quote:
Were you to be using grub (classic) your procedure [ws]ould have worked as you expected.
not sure about this, we are using grub comes with centOS 6.4 : grub (GNU GRUB 0.97).

Last edited by ajayyadavmca; 11-18-2013 at 07:17 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Puppy Lucid 5.2.5 Full -clean- install grub loader fails. WARemick Linux - Newbie 3 05-25-2011 08:32 PM
[SOLVED] Grub Loader -> Grub Page - > Linux Starts Up -> Erorrrrrrrrrr... Doesn't Start Up! Hi_This_is_Dev Linux - Server 5 09-07-2009 01:39 PM
How to change my Grub Loader to Lilo loader in REDHAT LINUX 9.0 skumar.v Linux - Newbie 3 04-04-2008 10:38 AM
GRUB LILO Boot loader fails mefrmdelhi Debian 1 09-21-2006 01:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration