LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-20-2003, 09:08 PM   #16
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68

hmmm... That's truly odd. Try umounting the device:
umount /mnt/c
And then remounting as a user:
mount /mnt/c
Then attempt to enter and list the files in the directory.
 
Old 01-20-2003, 09:12 PM   #17
android1654
Member
 
Registered: Jan 2003
Location: Baltimore
Distribution: Slackware,peanut linux
Posts: 30

Rep: Reputation: 15
ok, yeah im thinking it might be for some weird reason because we are both having the same exact symptoms and using redhat 8.0. im pretty sure i tried mounting as user, but i get an error saying user does not have permisssino to mount that
 
Old 01-20-2003, 09:13 PM   #18
android1654
Member
 
Registered: Jan 2003
Location: Baltimore
Distribution: Slackware,peanut linux
Posts: 30

Rep: Reputation: 15
mount: only root can do that
 
Old 01-20-2003, 09:27 PM   #19
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
So even if you only try to mount it with:
mount /mnt/c

It still returns to you saying "mount only root can do that"? Not issuing the whole command, just "mount /mnt/c"?
 
Old 01-20-2003, 09:37 PM   #20
android1654
Member
 
Registered: Jan 2003
Location: Baltimore
Distribution: Slackware,peanut linux
Posts: 30

Rep: Reputation: 15
umount /mnt/c
mount /mnt/c
mount: wrong fs type, bad option, bad superblock on /dev/hda1,
or too many mounted file systems
 
Old 01-20-2003, 10:14 PM   #21
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
After the umount, check to make sure it actually unmounted with:
mount

So:
umount /mnt/c
mount
Look at the list, check your modules:
lsmod
Look for the ntfs module
If all looks good, the drive is unmounted, and the module is loaded, then try again:
mount /mnt/c
 
Old 01-21-2003, 12:37 AM   #22
macshark
LQ Newbie
 
Registered: Dec 2002
Posts: 18

Rep: Reputation: 0
was able to unmount and mount the partition, as user, but the message "ls .: permission denied" appears when i access the windows partition and type ls at the command line.

interestingly, after i umount /mnt/windows , i typed "ls", it lists windows, and i can enter that parition, run ls, but the contents are not displayed. no permissio denied message too.

but if i were to type mount at the command line, the ntfs parition is not listed. strange....
 
Old 01-24-2003, 06:15 AM   #23
paulten
LQ Newbie
 
Registered: Jan 2003
Location: Norway
Distribution: Debian unstable, Redhat 8.0 7.2
Posts: 26

Rep: Reputation: 15
Hey

I had the same problem when mounting a ntfs partition here in school.

I solved it by typing "id" as a
output : uid=500(paul)

mount /dev/hda1 /mnt/win -o uid=500

When you type "mount"
You will see it's mounted as (rw,uid=500)

Hope this helps if you dident already solve it!
Paul
 
Old 01-24-2003, 08:58 AM   #24
macshark
LQ Newbie
 
Registered: Dec 2002
Posts: 18

Rep: Reputation: 0
it worked! thks

the line that i used in /etc/fstab

/dev/hda5 /mnt/windows ntfs uid=500
 
Old 11-11-2010, 04:57 AM   #25
Solution
LQ Newbie
 
Registered: Nov 2010
Posts: 2

Rep: Reputation: 0
Thumbs up

Thx a lot. It solved exact the same problem on Simply Linux.
Adding -o uid=500
BUT! it's readonly
I am looking for a way to mount for r/w, with an access for any group/user.
Even if i mount as a root iam still unable to rewrite content.
Could any one give some idea how to make ntfs read/write ? thx u.
P.S. chmod doesnt help
 
Old 11-11-2010, 05:10 AM   #26
Solution
LQ Newbie
 
Registered: Nov 2010
Posts: 2

Rep: Reputation: 0
UPS !
This is a solution for mounting Ntfs with read & write options :
[root@host-101 Desktop]# mount -t ntfs-3g /dev/sda5 /home/solution/Vault -o uid=500
I have tested it on Simply Linus, worked perfect.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can't access ntfs partition as normal user rezzie Linux - Newbie 6 11-26-2005 09:09 AM
NTFS partition access rr_rr_29 Linux - Hardware 1 10-17-2005 05:59 AM
how 2 access my ntfs partition jamie7676 Red Hat 3 03-31-2005 01:27 PM
How to access NTFS partition? silvershani Linux - Software 1 02-26-2005 08:16 AM
Can't access NTFS partition as regular user Spasmolytic Linux - Newbie 3 05-13-2004 06:46 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration