LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-12-2004, 06:43 PM   #1
TippyToes
Member
 
Registered: Jun 2003
Posts: 130

Rep: Reputation: 15
Unhappy Why do some games run slow and jerky?


Hello

I have a modern, one year old PC with lots of memory, etc and Fedora Core 1#/Gnome installed. However, I've had this problem on other computers as well and I swear I can't figure it out.

What is going on is that when I try to run Tux Racer, FooBillard, Flight Gear and a few other really popular Linux games, they run very slow and jerky and there's this long delay when I try to move the cursor or when a prop in the game moves.

I think someone mentioned something about needing to download OpenGL but I'm not sure if there is a version of this for Fedora or even where I would find an easy-to-install RPM for it. Could it be my graphics card?. Do I need a super-powerful one to run these games or maybe just upgrade my graphics card drivers?. I just have no idea.

Please help me if you can and thank you!!
 
Old 01-12-2004, 06:59 PM   #2
mint567
Member
 
Registered: Nov 2003
Location: Georgia
Distribution: Slackware 10.2
Posts: 75

Rep: Reputation: 15
If you would list some of your pc specs that would help. Overall it sounds like you need to install the proper video/opengl drivers for your video card. Provide more information and hardware specific and more advice and help can be provided.
 
Old 01-12-2004, 07:01 PM   #3
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,294

Rep: Reputation: 138Reputation: 138
Post your graphics card. To test your 3d performance, run the following in a console:

$ glxgears

A window will popup with some spinning gears. Let it run for a while and you will get a printout of your fps in the console. Post that as well.
 
Old 01-12-2004, 07:39 PM   #4
TippyToes
Member
 
Registered: Jun 2003
Posts: 130

Original Poster
Rep: Reputation: 15
Hey, thank's for the speedy reply!

Ok, there's a sysinfo command for Linux that displays all your system specs at a glance in the terminal but I forgot what it is. If I can get that info I'd display it here because I'd like to know myself (especially what graphics card is in this thing).

The other info (and it just keeps going and going so I had stop it) is ...

[freddy@localhost freddy]$ $ glxgears
bash: $: command not found
[freddy@localhost freddy]$ glxgears
Xlib: extension "XFree86-DRI" missing on display ":0.0".
654 frames in 5.0 seconds = 130.800 FPS
842 frames in 5.0 seconds = 168.400 FPS
1224 frames in 5.0 seconds = 244.800 FPS
918 frames in 5.0 seconds = 183.600 FPS
994 frames in 5.0 seconds = 198.800 FPS
995 frames in 5.0 seconds = 199.000 FPS
994 frames in 5.0 seconds = 198.800 FPS
918 frames in 5.0 seconds = 183.600 FPS
995 frames in 5.0 seconds = 199.000 FPS
1071 frames in 5.0 seconds = 214.200 FPS
994 frames in 5.0 seconds = 198.800 FPS
995 frames in 5.0 seconds = 199.000 FPS
994 frames in 5.0 seconds = 198.800 FPS
995 frames in 5.0 seconds = 199.000 FPS
994 frames in 5.0 seconds = 198.800 FPS
995 frames in 5.0 seconds = 199.000 FPS
994 frames in 5.0 seconds = 198.800 FPS
995 frames in 5.0 seconds = 199.000 FPS
994 frames in 5.0 seconds = 198.800 FPS
995 frames in 5.0 seconds = 199.000 FPS
994 frames in 5.0 seconds = 198.800 FPS
995 frames in 5.0 seconds = 199.000 FPS
994 frames in 5.0 seconds = 198.800 FPS
995 frames in 5.0 seconds = 199.000 FPS
994 frames in 5.0 seconds = 198.800 FPS
995 frames in 5.0 seconds = 199.000 FPS
994 frames in 5.0 seconds = 198.800 FPS
995 frames in 5.0 seconds = 199.000 FPS
994 frames in 5.0 seconds = 198.800 FPS
995 frames in 5.0 seconds = 199.000 FPS
994 frames in 5.0 seconds = 198.800 FPS
995 frames in 5.0 seconds = 199.000 FPS
994 frames in 5.0 seconds = 198.800 FPS
995 frames in 5.0 seconds = 199.000 FPS
994 frames in 5.0 seconds = 198.800 FPS
1066 frames in 5.0 seconds = 213.200 FPS
918 frames in 5.0 seconds = 183.600 FPS
994 frames in 5.0 seconds = 198.800 FPS
1071 frames in 5.0 seconds = 214.200 FPS
995 frames in 5.0 seconds = 199.000 FPS
994 frames in 5.0 seconds = 198.800 FPS
995 frames in 5.0 seconds = 199.000 FPS
994 frames in 5.0 seconds = 198.800 FPS
995 frames in 5.0 seconds = 199.000 FPS
994 frames in 5.0 seconds = 198.800 FPS
995 frames in 5.0 seconds = 199.000 FPS
994 frames in 5.0 seconds = 198.800 FPS
995 frames in 5.0 seconds = 199.000 FPS
994 frames in 5.0 seconds = 198.800 FPS

And when I stopped it...

X connection to :0.0 broken (explicit kill or server shutdown).
[freddy@localhost freddy]$

Hope this helps. These games are so cool but I have never been able to play them. Thank you again!
 
Old 01-12-2004, 09:05 PM   #5
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,294

Rep: Reputation: 138Reputation: 138
Those fps really suck. No wonder your games aren't running well. Try running this in a console:

$ lspci

It should give a printout of everything on the pci bus including your graphics card. Post the output here. We need to know your graphics card to give any meaningful help.

By the way, the "$" is just the prompt for an ordinary user; you don't include that in the command but I guess you figured that out. When in a console as root the prompt will change to "#". The convention is to use either "$" or "#" to let people know if they need to be root to run the command or if you can run it as an ordinary user.

Last edited by kilgoretrout; 01-12-2004 at 09:11 PM.
 
Old 01-12-2004, 09:19 PM   #6
TippyToes
Member
 
Registered: Jun 2003
Posts: 130

Original Poster
Rep: Reputation: 15
Ok, I tried it and I'm getting this...

[freddy@localhost freddy]$ lspci
bash: lspci: command not found
[freddy@localhost freddy]$
 
Old 01-12-2004, 10:41 PM   #7
Dmjit
LQ Newbie
 
Registered: Jan 2004
Posts: 6

Rep: Reputation: 0
Try this :

$ /sbin/lspci

This is the command for Redhat 9, it's probably the same.
 
Old 01-12-2004, 11:01 PM   #8
TippyToes
Member
 
Registered: Jun 2003
Posts: 130

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Dmjit
Try this :

$ /sbin/lspci

This is the command for Redhat 9, it's probably the same.
Hah, it worked

VIA Technologies, Inc. VT8633 [Apollo Pro266 AGP]

So now what do we do?
 
Old 01-12-2004, 11:30 PM   #9
rmanocha
Member
 
Registered: Oct 2003
Location: Austin,TX
Distribution: Debian SID-->fully content-->Love APT,kernel 2.6.4
Posts: 327

Rep: Reputation: 30
well i dont know about Fedoa but Suse does not enable 3D support for the graphics card by default...so maybe you will have to go through the config utility of fedora and enable 3d acceleration...for this you will need to have your graphics card drivers installed.....now i dont know much about the card u listed above...so u should probably try googling about it to find out the driver it uses...once u have done that issue this command as root:
lsmod
see is the module name in the driver is present in the list displayed after the above command....if it is...then you are good to go....enable 3d and play....else you will probably have to install the drivers,etc.
good luck
 
Old 01-13-2004, 06:04 AM   #10
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,294

Rep: Reputation: 138Reputation: 138
You have a via motherboard with integrated graphics. Did a little googling and can see that this mb/chipset is problematic in linux. There seems to be some trouble enbling the agp bus. Saw this work around in one forum. Try running the following:

$ su
<enter your root password>
# modprobe agpgart agp_try_unsupported=1

If the module loads OK(i.e. no error messages with the above), then run glxgears again:

$ glxgears

See if you get any improvement in your fps.
 
Old 01-13-2004, 02:04 PM   #11
TippyToes
Member
 
Registered: Jun 2003
Posts: 130

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by kilgoretrout
You have a via motherboard with integrated graphics. Did a little googling and can see that this mb/chipset is problematic in linux. There seems to be some trouble enbling the agp bus. Saw this work around in one forum. Try running the following:

$ su
<enter your root password>
# modprobe agpgart agp_try_unsupported=1

If the module loads OK(i.e. no error messages with the above), then run glxgears again:

$ glxgears

See if you get any improvement in your fps.
Ok, here's what I got...

[root@localhost freddy]# modprobe agpgart agp_try_unsupported=1
bash: modprobe: command not found
[root@localhost freddy]#

I also went into my Fedora control panel settings where it say's "configure video card" and all I get is a way to change to a different card but not actually configure the one that is currently installed.

Is there some other (easy) way to do this?
 
Old 01-13-2004, 02:10 PM   #12
php
Member
 
Registered: Jun 2001
Location: USA
Distribution: Slackware
Posts: 824

Rep: Reputation: 30
You have yet to post what graphics card you have
 
Old 01-13-2004, 02:18 PM   #13
TippyToes
Member
 
Registered: Jun 2003
Posts: 130

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by hackers_
You have yet to post what graphics card you have
Actually, I posted this yesterday (not sure if it is the information you needed though). Hmmm...now that I look at it again it does'nt even say it's a 3D card so maybe that's the whole problem. Should I try another video card and then selecting it from the list in Fedora's config tool?. Anyway, here's what I have...

VIA Technologies, Inc. VT8633 [Apollo Pro266 AGP]

UPDATE: I just installed a Voodoo 3 graphics card. Fedora configured it automatically and it works but I'm STILL getting the slow and jerky gameplay...ahhh!!!

Last edited by TippyToes; 01-13-2004 at 03:15 PM.
 
Old 01-13-2004, 03:17 PM   #14
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,294

Rep: Reputation: 138Reputation: 138
Try doing /sbin/modprobe instead of modprobe. Keep forgetting you don't have /sbin in PATH so you have to designate the full path to the command. I always found that to be one of the annoying things about redhat.

It's a motherboard problem from what I've found using google. No matter what card you have in there, you have problems enabling agp.

Last edited by kilgoretrout; 01-13-2004 at 03:18 PM.
 
Old 01-13-2004, 06:05 PM   #15
php
Member
 
Registered: Jun 2001
Location: USA
Distribution: Slackware
Posts: 824

Rep: Reputation: 30
Unless you can find hardware accelerated drivers for either of this video devices, you will have crappy performance. By hardware accelerated, for example, the nvidia.com drivers they distribute that allow for open gl, etc.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Old games run wayyy too slow with wine drawhla Linux - Games 3 08-22-2004 10:08 PM
Games too slow hank@$3800 Linux - Games 1 03-31-2004 08:43 PM
Games too slow! jelitegamer Linux - Games 11 03-31-2004 03:49 PM
sdl games are slow extremely slow linksocc Linux - Software 7 01-17-2004 03:53 PM
Java games run VERY slow in linux jleejj Linux - Software 0 10-14-2003 03:16 AM


All times are GMT -5. The time now is 07:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration