LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Why did this recent Ubuntu update kill Giver? (https://www.linuxquestions.org/questions/linux-software-2/why-did-this-recent-ubuntu-update-kill-giver-908354/)

teboil12 10-15-2011 04:36 PM

Why did this recent Ubuntu update kill Giver?
 
I love using Giver and I need it, but when updating to Ubuntu 11.10 I noticed that it was removed. Tried to re-install it, even " succeeded" but it won't start. What is wrong??? Shall I change to some other programme instead of Giver or what?

macemoneta 10-15-2011 08:17 PM

It's apparently a known bug. You should add yourself to the bug.

Update: There's a workaround in this bug report:

There is a workaround for this bug. Just install "libx11-6" and "libx11-dev" and giver should run.

teboil12 10-16-2011 06:09 AM

libx11-6 and libx11-dev are there already. Re-installed, to no use. What now?

macemoneta 10-16-2011 07:06 AM

When you start it in a terminal session, what happens?

teboil12 10-16-2011 11:56 AM

I completely removed Giver and tried to re-install it from a tarball, but when configuring it tells me that something called "notify-sharp" is missing, so it stops right there. Cannot even find Giver in Synaptics, cannot find it in the Ubuntu software centre, when trying the terminal solution with sudo apt-get install giver it tells me that there is no such package...
So this is a real mess, cannot even find any deb packages to try out.

teboil12 10-16-2011 12:51 PM

FYI

I found a deb package and reinstalled Giver, but it won't run, so I'm back to square 1. Why did it work OK in 11.04 and now all of a sudden not at all in 11.10? Someone out there, do you share the same experience???

itsjustarumour 11-14-2011 04:50 PM

Quote:

Originally Posted by teboil12 (Post 4499928)
Someone out there, do you share the same experience???

Exactly the same problem here... Giver worked fine in Ubuntu 11.04 but not in 11.10... both of the required packages were already installed on my machine (tried reinstalling them), so the workaround in the bug report didn't work for me either... :-(

EDIT - sorry Teboil, I just released it was you that also posted on the Ubuntu Forum! :-)

teboil12 12-02-2011 03:46 AM

Hello itsjustarumour and everybody else!!!

Take a look at Web Upd8! Just a couple of days ago they (Andrew) gave a solution about how to solve the problem, and thanks to him I have Giver up and going again! Look in "Get Giver To Work In Ubuntu 11.10 And 11.04 [Quick Tip]".

Thank you ever so much to Andrew!

itsjustarumour 02-19-2012 01:05 AM

Quote:

Originally Posted by teboil12 (Post 4539995)
Hello itsjustarumour and everybody else!!!

Take a look at Web Upd8! Just a couple of days ago they (Andrew) gave a solution about how to solve the problem, and thanks to him I have Giver up and going again! Look in "Get Giver To Work In Ubuntu 11.10 And 11.04 [Quick Tip]".

Thank you ever so much to Andrew!

Hi Teboil,

Yes, I saw that - good to have it working again! :)

Best,

itsjustarumour


All times are GMT -5. The time now is 12:17 AM.