LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-11-2008, 11:45 PM   #1
cricketlong
Member
 
Registered: Dec 2008
Posts: 52

Rep: Reputation: 15
why can't I mount a device automatically when logging in?


I appended a line written bellow to the file "/etc/fstab" in Ubuntu 8.04:
/dev/sda5 /mnt/windows_D vfat silent,uid=1000,utf8 0 0

but there is nothing in the directory "/mnt/windows_D" after I rebooted.And if I click on the volumn(/dev/hda5),an error box showing "You are not privileged to mount the volumn" appears.

But if I mount the device with command "sudo mount /dev/hda5 /mnt/windows_D" in terminal,it succeeded.

How should I make the volumn automatically mounted by system when logging in?

Any help would be appreciated.

Last edited by cricketlong; 12-11-2008 at 11:47 PM. Reason: correcting some words
 
Old 12-12-2008, 12:52 AM   #2
IMNOboist
Member
 
Registered: Nov 2003
Location: Seattle
Distribution: OpenBSD, Ubuntu
Posts: 60

Rep: Reputation: 16
Have you tried this:
/dev/sda5 /mnt/windows_D vfat defaults 0 0

And you don't need to reboot to check if it works. Just do:
sudo mount -a
 
Old 12-12-2008, 12:57 AM   #3
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Gurgaon, India
Distribution: Cent OS 6/7
Posts: 4,629

Rep: Reputation: Disabled
You need to be a super user to use mount command in Ubuntu Hardy and for that matter in most of the distros. Hence using sudo works. Just edit the fstab file as advised in the earlier post and reply if it works out.
 
Old 12-14-2008, 01:55 AM   #4
cricketlong
Member
 
Registered: Dec 2008
Posts: 52

Original Poster
Rep: Reputation: 15
I tried "/dev/sda5 /mnt/windows_D vfat defaults 0 0"
but it was the same as I used "/dev/sda5 /mnt/windows_D vfat silent,uid=1000,utf8 0 0"

but I can mount NTFS volumn automatically when logging in with the following line:
/dev/sda6 /mnt/windows_E ntfs-3g silent,unmask=0,locale=utf8 0 0


Thanks to all
 
Old 12-14-2008, 07:33 AM   #5
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Gurgaon, India
Distribution: Cent OS 6/7
Posts: 4,629

Rep: Reputation: Disabled
Go through the logs and tell if there is some error.......if some post it.
 
Old 12-19-2008, 04:36 AM   #6
cricketlong
Member
 
Registered: Dec 2008
Posts: 52

Original Poster
Rep: Reputation: 15
which log file contains the info about mounting a device?
 
Old 12-20-2008, 11:31 PM   #7
cricketlong
Member
 
Registered: Dec 2008
Posts: 52

Original Poster
Rep: Reputation: 15
it is OK now.
That was my mistake.
I made a invalid option in the line "/dev/sda5 /mnt/windows_D vfat default 0 0".
It should be "/dev/sda5 /mnt/windows_D vfat defaults 0 0"

Thanks to all!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to automatically mount a USB device jayhel Slackware - Installation 2 07-17-2007 11:27 AM
Automatically mount a device upon boot? epsilon72 Linux - Hardware 2 03-13-2007 01:01 PM
automatically logging in? bobbens Debian 2 11-01-2004 06:49 AM
device mount automatically caterboy Slackware 3 06-04-2004 10:01 PM
how to mount the joystcik device automatically? lpriyamb Linux - Software 7 10-30-2003 12:22 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration