LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Whoops with prelink (https://www.linuxquestions.org/questions/linux-software-2/whoops-with-prelink-296026/)

andrewjg 02-28-2005 07:08 PM

Whoops with prelink
 
Had a bit of a disaster with prelink this morning when following instructions to get wine working in Fedora Core 2 (but I think the solution will not be fedora-specific). Basically I did:

prelink -ua
followed by
prelink -am --no-exec-shield

but during the second run of prelink, managed to hit Ctrl-C by mistake. That caused big problems. Trying to run anything (e.g. ls) resulted in errors such as "unable to load shared library: invalid ELF header". When I try to reboot, I get a kernel panic with similar errors, and "tried to kill init". I rebooted with the rescue CD, but was unable to do anything other than back up data. As soon as I chroot to /mnt/sysimage, everything stops working with invalid ELF header errors.

I'm hoping someone can suggest how I salvage the situation without reinstalling ;) I already tried running 'prelink -ua' to undo changes, but get complaints about libraries not being in ELF format.

Thanks...

Engmar 03-02-2005 05:08 PM

You could just try running /etc/cron.daily/prelink, but I have a sinking feeling that you may have to do a re-install.

andrewjg 03-02-2005 07:16 PM

Re:
 
Thanks, decided to upgrade to FC3 yesterday afternoon. It seemed a question of waste the afternoon doing that, or waste the next week trying to get FC2 back ....


All times are GMT -5. The time now is 04:15 AM.