LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-31-2009, 07:34 PM   #1
123sun
LQ Newbie
 
Registered: Sep 2009
Posts: 9

Rep: Reputation: 0
Which rpm packages has few dependences? help me please with my homework


hi, i need to install a program with a rpm package, but the requirement is that the rpm have few dependences, because i have to install it in class. Every program i know had a lot of dependences, so i need a list with some ideas. My distribution is fedora core 5 or 8.

thanks a lot for your help.
 
Old 10-31-2009, 08:07 PM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 475Reputation: 475Reputation: 475Reputation: 475Reputation: 475
Try one of the ones that don't need X - like Nano, which is a terminal based text editor and as far as I know doesn't need any extra programs that aren't installed as base.

But that's a really odd question to be asked. Do you know why your tutor would require this? Most distros would install packages from a central server and would resolve their own dependencies. So you would be using YUM to install them.
 
Old 10-31-2009, 08:45 PM   #3
Elv13
Member
 
Registered: Apr 2006
Location: Montreal,Quebec
Distribution: Gentoo
Posts: 825

Rep: Reputation: 129Reputation: 129
Make one if you want, it is not that hard and don't have to have dependencies.
 
Old 10-31-2009, 09:07 PM   #4
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,363

Rep: Reputation: 172Reputation: 172
Keep in mind that both FC5 and F8 are well beyond EOL(End OF Life). There will be and have not been any updates of any kind in quite a while.
 
Old 10-31-2009, 09:25 PM   #5
123sun
LQ Newbie
 
Registered: Sep 2009
Posts: 9

Original Poster
Rep: Reputation: 0
My tutor require this to teach us how to install rpm packages and then yum. I'll search for nano and i'll investigate how to create a rpm package. If you remember any other program that i can install, it would be great. Thanks a lot for your fast answers.
 
Old 10-31-2009, 09:29 PM   #6
handydan
Member
 
Registered: Mar 2005
Location: palmdale, california
Distribution: MEPIS 8; Debian (stable/testing)
Posts: 83

Rep: Reputation: 23
One begins to suspect...

Quote:
Originally Posted by 123sun View Post
hi, i need to install a program with a rpm package, but the requirement is that the rpm have few dependences, because i have to install it in class. Every program i know had a lot of dependences, so i need a list with some ideas. My distribution is fedora core 5 or 8.

thanks a lot for your help.
One begins to suspect that yer perfesser might have intended for you to learn the niceties of the rpm command.
You could do this by typing, at a terminal emulator,
Code:
man rpm
Lots more work than cheating, but more profitable, too.



 
Old 11-01-2009, 04:05 PM   #7
123sun
LQ Newbie
 
Registered: Sep 2009
Posts: 9

Original Poster
Rep: Reputation: 0
which is the object of seeing man rpm if a don't see how this could work on a package? maybe my teacher wants to teach us how to do it and then with yum, for what he said when he give us the homework.

thanks for all the answers .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
FC10 command line install using RPM, can't find dependences MrUmunhum Fedora 6 04-08-2009 01:52 PM
RPM 'failed dependencies': Why can I not install any rpm packages? leontini Linux - Newbie 7 09-16-2003 12:44 AM
error: cannot get exclusive lock on /var/lib/rpm/Packages error: cannot open Packages inward_eye Linux - Software 3 08-24-2003 03:07 PM
creating packages (.tgz/.deb/.rpm) How from the source packages? l_9_l Linux - General 1 03-06-2002 06:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration