Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 10-08-2012, 07:04 AM   #1
Registered: Sep 2012
Posts: 372

Rep: Reputation: 1
Where to enable printer in CUPS

Successfully installed hplip 3.12.10 on Slackware 13.37.
Single page test OK
Added printer by another name.
When I printed test page from it I got a message in HP Toolbox telling me to follow the diagnostic trail, which I did.
It first concluded that the printer while flagged (erroneously??) as shared the system wasn't sharing the printer.
The diagnostic trail concluded that I should in CUPS (1.4.6) go to System>Administration>Printing (not Print). And there to change Policies to "Enable".
CUPS does not have that System>Administration>Printing path. I finally found Policies but there is no option to select Enable.
Can someone suggest a clue or help?
I looked for enable (thought it was removed) it isn't in man pages but sure got a long list when I hit return on that word. Nothim useful tho.
Old 10-09-2012, 09:35 AM   #2
LQ Veteran
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2, current, slackware-arm-currnet
Posts: 5,456

Rep: Reputation: 628Reputation: 628Reputation: 628Reputation: 628Reputation: 628Reputation: 628
Go into cups, from a web browser, enter http://localhost:631 and press enter. You should get the Cups web interface. Click the Admin tab. Select 'modify' on the right drop down. You will be prompted for a user and password. Enter root for user and the root password. You should get a list of printers. Click the printer in question. On the first screen, nothing to change, click continue. On the second screen there is a check box for "Share This Printer". Check it, continue, until you have all the changes needed, then Save on the last page.

That should share your printer.
Old 10-10-2012, 03:30 AM   #3
Registered: Sep 2012
Posts: 372

Original Poster
Rep: Reputation: 1
Where to enable printer in CUPS

I tried all of that. The problem was the CUPS was telling me to set Policies to enabled and when I get into Policies there is not way to "enable". Someone didn't proof read or check the software is my guess.
What I did was went back and on the printer which was working I set it to NOT share printer. When that worked I did the same for the second printer (same hardware) and walla it too now works.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] HELP!!!!!!!!!!!!!How to enable Printer in CUPS using Command Line. tailinlinux Linux - Newbie 3 05-19-2011 09:39 PM
CUPS and Canon MP190 printer. Print quality and printer sharing... SFGAirborne Linux - Hardware 1 12-14-2010 06:55 AM
CUPS problem - connecting to local printer as well as CUPS server bobm2011 Linux - Newbie 4 01-11-2010 08:28 AM
cups to cups printing through network on usb printer checkmate3001 Linux - Server 2 02-16-2009 01:12 PM
CUPS Network Printer/ server indicator blinks no printer output wine Linux - Networking 8 03-18-2006 11:20 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:28 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration