LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Where is yum-complete-transaction? (https://www.linuxquestions.org/questions/linux-software-2/where-is-yum-complete-transaction-4175595810/)

billsee 12-20-2016 03:05 PM

Where is yum-complete-transaction?
 
I know this has been addressed before on the forum but the issue
was not resolved. I am getting transaction not complete pop up
errors in CentOS 6.8 apparently because I stopped a yum install
before it was completed. I have installed the yum-utils package
which is supposed to contain yum-complete-transaction but it is
not found. This command to supposed to clean up the dangling transaction.

MensaWater 12-20-2016 03:48 PM

On my RHEL6.8 system:

which yum-complete-transaction
/usr/sbin/yum-complete-transaction

rpm -qf /usr/sbin/yum-complete-transaction
yum-utils-1.1.30-37.el6.noarch

Since CentOS is compiled from RHEL source it should be the same package and location on CentOS6.8.

If you run "rpm -ql yum-utils" does it show it?

billsee 12-20-2016 08:24 PM

The problem was I did not have /usr/sbin in my search path. I ran /usr/sbin/yum-complete-transaction and it solved the problem. I have put /usr/sbin in my search path.
Thanks for the fix.

John VV 12-22-2016 02:08 AM

your NORMAL user will NOT have that folder in it $PATH !
that is whay there is a " sbin" folder

only ROOT can use those programs so only root has that folder in is's path
-- this is the default setting on rhel and basically every linux os

billsee 12-22-2016 10:15 AM

OK, I will take it out of my path and run the command as as root.


All times are GMT -5. The time now is 08:35 AM.