-   Linux - Software (
-   -   where is (

mreff555 05-11-2012 04:53 PM

where is
I'm trying to satisfy dependancies for gimp 2.8

I've been trying to install glib 2.32.1 but I'm getting errors loading

It doesn't appear to be installed on my system. I have installed libffi 3.0.11 and it appears to correctly install but still not

any suggestions?

blue_print 05-11-2012 10:58 PM

Aren't you able to find the package in /usr/lib?

If it is a rpm based installation, please use the following command,


rpm -ql libffi
This will give you the path of libffi so file

knudfl 05-12-2012 12:24 AM

Still the Debian Sid based Crunchbang ?

Today's Debian Sid has libglib2.0-0 version 2.32.2,
and it uses libffi5 :

If you have the from libffi 3.0.11 in a hideaway location,
glib 2.32.1 may not be able to find it.

Anyway, gimp-2.8.0 will do fine with glib-2.30.2, which is often
compiled to use or


mreff555 05-12-2012 08:14 AM

Thanks guys.

here is what I had in my /usr/lib

dan@hobo:~/downloads/glib-2.30.2$ ls -l /usr/lib/libffi*
lrwxrwxrwx 1 root root    16 Mar 25 07:38 /usr/lib/ ->
-rw-r--r-- 1 root root 31792 Oct  1  2010 /usr/lib/

I tried glib-2.32.2 but it appears to be also looking for
2.30.2 seems to have installed ok. I guess I'll give that a try

mreff555 05-12-2012 08:54 AM


Gimp 2.8 also requires Pango >= 1.29.4 which requires arggggg!

knudfl 05-12-2012 09:13 AM

Where do you get those strange packages that require ? ?

The current Debian Sid : libpango ver. 1.30.0 :
Depends on a glib2, built with ->

Which OS are you using ? Version ?


mreff555 05-12-2012 09:20 AM

I was trying to compile from source

knudfl 05-12-2012 09:44 AM

I did a gimp-2.8.0 build on Suse 12.1 yesterday.
That's the one with the "old" libffi-4.6.2 : -> !
And pango-1.29.4 is the default installed system version.

No issues at all.

All times are GMT -5. The time now is 06:44 AM.