-   Linux - Software (
-   -   Where is gone on linux 64 system? (

AleLinuxBSD 09-05-2010 01:32 AM

Where is gone on linux 64 system?
I use the package taken directly from java and when yesterday i decided to upgrade from jdk 1.6.0_18 to 1.6.0_21 i don't find this file.

Happen the same thing that happen with flash?
Where isn't more present the 64 bit version?

Now i installed the same version of Java on a 32 bit linux system and i noticed that for that system that plugin is present.

evo2 09-05-2010 09:42 PM

What os/distro are you running? If it is debian based, and you have the relevant entries in your /etc/apt/sources.list, "apt-file" is your friend.

Generic hint: if the file is already on your system you can use "locate" or "find".


rokytnji 09-05-2010 09:57 PM

My Plugin in Iceape


Java(TM) Plug-in 1.6.0_21

File name:
The next generation Java plug-in for Mozilla browsers.
32 bit by the way. AntiX does not make a 64bit distro.

Shows the same in my Firefox 4 Beta 4 install also as the same plugin.

craigevil 09-06-2010 01:04 AM

On what distro? You have 8 listed.

apt-get install sun-java6-plugin

Works the same on Debian and Ubuntu, on 32bit and 64bit.


Java(TM) Plug-in 1.6.0_21

Filename /usr/lib/jvm/java-6-sun-
Plugin Version:
Plugin Description: The next generation Java plug-in for Mozilla browsers.
$ apt-cache policy sun-java6-plugin
Installed: 6.21-1
Candidate: 6.21-1
Version table:
*** 6.21-1 0
500 sid/non-free i386 Packages
100 /var/lib/dpkg/status

AleLinuxBSD 09-06-2010 03:55 AM

I use the package taken directly from oracle sun because i prefer don't rely on package taken by the single distro so i'm more free to update when i like update indipendently by the presence of the package on the specific distro that i use.

Generally I prefer share the jdk between all the distro so i put it on a separated partition.

Then the fact that right now I'm using debian 64 squeeze don't matter.

I think i remove some distro that i used less (as sabayon and opensuse) and on future probably even OpenSolaris given that thanks to Oracle this project is dead. :-/

evo2 09-06-2010 03:58 AM

If you are getting it directly from Oracle then check the documentation that comes with the software.



AleLinuxBSD 09-06-2010 04:13 AM

I read this:
Manual Installation and Registration of Java Plugin for Linux
but speak only about the 32 bit version.

JDK Self-Extracting Installation for Linux (64-bit)
No mention about that plugin.

Supported System Configurations

Browser Footnotes

* Browsers listed above are supported for Java™ Plug-in software and Java™ Web Start software.
See the Deployment Footnotes for more detail.
* Google Chrome 4.0 support was added in 1.6.0_21.
* Firefox 3.6 support was added in 1.6.0_18.
* Firefox 3.5.1 support was added in 1.6.0_16.
* Support for IE 8 was introduced in 1.6.0_13.

Deployment Footnotes

* For Java Plug-in and Java Web Start on 64-bit Solaris systems, use the 32-bit JRE.
* For Java Plug-in and Java Web Start on 64-bit Windows systems, the 64-bit JRE is supported as of 1.6.0_12.
* For Java Plug-in and Java Web Start on 64-bit Linux systems, support is not offered at this time.
Mmm. So i think is necessary use the plugin for the 32 bit version. :/

AleLinuxBSD 09-06-2010 10:01 AM

Upgrade about the situation.
I copied:
Using about:plugins
i see it.

But when i try to test it:
What Version of Java Are You Using?
firefox 3.6.8 (taken directly from mozilla) crash immediately
firefox 4.x (taken directly from mozilla) don't crash only because the plugin remain disable

rokytnji 09-06-2010 08:01 PM

Mine are in


only. Iceape 2.0.6 and Firefox 4 symlink to that folder for plugins.

Even though I launch and keep Firefox 4 folder in /home.

Mine pass the java test and don't crash.

AleLinuxBSD 09-07-2010 01:53 AM

1 Attachment(s)
Even after that change the problem remain absolutely identical as before. :(

I add the screenshoot about firefox 4.

Don't work.

firefox 3.6: crash

craigevil 09-07-2010 06:52 AM

PluginDoc: Linux (x86)

Do not copy the plugin to your plugins directory. If you do, Mozilla will crash any time you attempt to view a page containing a Java applet.

AleLinuxBSD 09-08-2010 02:48 AM

Ok i put the symlink about
jdk1.6.0_21/jre/lib/i386/ (using the jdk 32 bit release)
(while if i tried the symlink with the file that came with the jdk 64 bit release don't work
and now firefox 3.6.x don't crash.
While on firefox 4.x that plugin remain disable.

I put solved on that topic given that many plugin don't work on firefox 4.x.

All times are GMT -5. The time now is 08:12 AM.