LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-29-2004, 08:16 PM   #1
amimusa
Member
 
Registered: Aug 2004
Location: Spain
Distribution: debian | ubuntu
Posts: 67

Rep: Reputation: 15
where can i found the .ko module


Hello, I have updated the kernel to the old one installing the image from a deb package. In the new boot I have some Module Not Found errors, and I think it is because they are not in the /lib/modules folder.
How can I get this modules ???
or...
If they are not in the new kernel version, is becasue they are not used now and then i have to comment the call line in /etc/modules ???
This last option is one solution, but i want to be sure that they are not needed modules.
The modules i have Not Found error for the 2.6.9-1 kernel are:
- usb-uhci
- input
- keybdev
- printer
- ipt_MIRROR
- ipt_unclean

and also i have some warnings about one device or resource busy always with the ipfwadm.ko module.

Thanks.
 
Old 12-29-2004, 09:22 PM   #2
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
How exactly did you install the kernel !?

it sounds to me like you only coppied the kernel image to the /boot/ folder, without installing the /lib/modules directory !?

is this so ?

from missing modules you have listed, its hard to say what the impact might be.

looks like your firewall, USB, mouse and keyboard will probably be useless.
 
Old 12-30-2004, 04:32 AM   #3
amimusa
Member
 
Registered: Aug 2004
Location: Spain
Distribution: debian | ubuntu
Posts: 67

Original Poster
Rep: Reputation: 15
Hi, before at all thanks for your response.
I have installed the kernel with the apt-get install command and just it.
Then I have made an update-modules. But just all.
I have to do something more???

Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Module sd_mod not found kramtoad Linux - Software 1 03-17-2006 01:59 PM
nvidia module not found shamgar03 Linux - Hardware 9 07-16-2005 11:42 PM
Module ohci1394 Not found zcrxsir88 Fedora - Installation 0 10-20-2004 10:53 AM
fglrx module not found but X runs using module biger problem though HELP! fireicer Linux - Newbie 4 07-30-2004 05:44 PM
Module ds not found LooOOooM Linux - Laptop and Netbook 1 02-23-2004 04:25 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration