LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-29-2017, 02:57 AM   #1
mimorek
LQ Newbie
 
Registered: Feb 2013
Distribution: Debian (jessie)
Posts: 6

Rep: Reputation: Disabled
When muting, Alsamixer mutes Master,Headphone,Speaker,PCM; but unmutes only Master.


Hi All,

I recently reinstalled Debian Jessie with xfce 4. All works fine except the mute/unmute function. When I mute the sound, the Master, Headphone, Speaker and PCM channels are muted. But when I unmute the sound only the Master channel is unmuted and all others remain muted.

I fixed this issue in my previous installation, but I can't remember how.

I tried searching the web without success.

Last edited by mimorek; 01-29-2017 at 03:04 AM.
 
Old 01-29-2017, 09:04 AM   #2
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 9,923
Blog Entries: 7

Rep: Reputation: 2444Reputation: 2444Reputation: 2444Reputation: 2444Reputation: 2444Reputation: 2444Reputation: 2444Reputation: 2444Reputation: 2444Reputation: 2444Reputation: 2444
which app are you using to do that? the terminal alsamixer, or some gui? show us?
also, isn't xfce4 using pulseaudio?
 
Old 01-29-2017, 10:39 AM   #3
mimorek
LQ Newbie
 
Registered: Feb 2013
Distribution: Debian (jessie)
Posts: 6

Original Poster
Rep: Reputation: Disabled
The gui program I'm using to control sound is xfce4-mixer and the terminal program is alsamixer. When I mute the Master channel, in either one, they both respond by muting said four channels.

Both xfce4-mixer and alsamixer show "HDA Intel (Alsa mixer)" as my sound card.


Thanks for your reply.
 
Old 01-29-2017, 11:34 AM   #4
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 9,923
Blog Entries: 7

Rep: Reputation: 2444Reputation: 2444Reputation: 2444Reputation: 2444Reputation: 2444Reputation: 2444Reputation: 2444Reputation: 2444Reputation: 2444Reputation: 2444Reputation: 2444
Quote:
Originally Posted by ondoho View Post
also, isn't xfce4 using pulseaudio?
tbh, i think it does (i might be wrong though).
it's an extra layer on top of alsa and might well be responsible for the behavior.
so instead of alsamixer, please use something like pavucontrol.
 
Old 01-29-2017, 03:25 PM   #5
mimorek
LQ Newbie
 
Registered: Feb 2013
Distribution: Debian (jessie)
Posts: 6

Original Poster
Rep: Reputation: Disabled
I installed pavucontrol and it does mute/unmute properly. But I can't control pavucontrol with my keyboard (mute, vol-, vol+) buttons.

I have made some steps though.

By setting the command 'amixer set Master toggle' to my keyboard mute-button, I'm now able to mute/unmute without a problem.

When I lower the volume to zero with my keyboard 'vol-' button, all 4 channels get muted and don't unmute when I use the 'vol+' button. If I press the keyboard 'mute' button they do unmute now.

So it's a workaround, but it works.

Thanks for your time Ondoho.

Last edited by mimorek; 01-29-2017 at 04:35 PM.
 
Old 01-30-2017, 03:25 AM   #6
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 9,923
Blog Entries: 7

Rep: Reputation: 2444Reputation: 2444Reputation: 2444Reputation: 2444Reputation: 2444Reputation: 2444Reputation: 2444Reputation: 2444Reputation: 2444Reputation: 2444Reputation: 2444
please understand that if you use pulseaudio, you should leave alsa settings (alsamixer, amixer ...) alone.
do all your adjustments via pulseaudio controls.
 
Old 01-30-2017, 04:14 AM   #7
mimorek
LQ Newbie
 
Registered: Feb 2013
Distribution: Debian (jessie)
Posts: 6

Original Poster
Rep: Reputation: Disabled
Ok.
Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help With Muting The Internal PC Speaker When Headphone Are Plugged In. mojo8850 Fedora 2 12-12-2012 06:44 PM
My alsamixer is missing PCM,Master and some other controls praveenya Linux - Hardware 1 08-30-2008 05:47 PM
Alsa don't work, can show alsamixer but no PCM or Master jazzi Linux - Hardware 3 07-23-2008 09:48 PM
How could I make USB speaker as default/master speaker ? czy11421 Linux - Hardware 1 09-02-2007 11:59 AM
Slack 11 / Alsa 1.0.13 + Master (Yes) PCM (NO) Daedra Slackware 3 12-14-2006 04:58 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration