LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   When Kubuntu w/KDE4.1 goes into "suspend", display will not come back on resume. (https://www.linuxquestions.org/questions/linux-software-2/when-kubuntu-w-kde4-1-goes-into-suspend-display-will-not-come-back-on-resume-660013/)

vince.fyre 08-02-2008 06:09 PM

When Kubuntu w/KDE4.1 goes into "suspend", display will not come back on resume.
 
Hi. I have an HP dv6000. I'm running Kubuntu, and I have KDE 4.1 installed. Before my screen goes into power save mode (standby) everything seems to be working normally. However, if I try to resume from standby by moving the mouse or pressing a button, the screen turns on and I am unable to see anything. It's a grey screen with colored lines running vertically, and they seem to move across the screen very slowly. This also happens if I close the laptop and then open it again. The only way for me to get the computer working again is to ctl-alt-del and restart the whole thing. I do have the newest NVIDIA driver installed and running. Anyone know what could be causing this? Any recommendations? I've read some other posts about APM and ACPI, but I have no idea what that means or how to change it.

matthewg42 08-03-2008 11:46 AM

I had the same problem with my machine which uses an nvidia Go5200 card in it.

The fix has a few parts:


1. Make sure you're using the restricted nvidia driver.

2. In the Device section of the /etc/xorg.conf file, add the NvAGP line. Here's what my Device section now looks like. The Dpi lines are probably not necessary. You only need to add the line in blue.
Code:

Section "Device"
        Identifier      "Configured Video Device"
        Driver          "nvidia"
        Option          "NoLogo"        "True"
        Option          "UseEdidDpi"    "True"
        Option          "Dpi"          "96x96"
        Option          "NvAGP"        "1"
EndSection

3. Then you need to tell the kernel not to load a few AGP related modules (so it will use th Nvidia one instead). Do this by creating a file in the /etc/modprobe.d directory. Call the file anything you like. A good name is nvidia_suspend_fix. It should contain this:
[/CODE]blacklist intel_agp
blacklist agpgart[/CODE]

I think that's all, unless I forgot something. Just reboot and it should work. Let me know if it works.

I gleaned this info from a couple of bug reports and some howtos. have a google for "nvidia ubuntu suspend nvagp" and you should find them.

matthewg42 08-03-2008 11:55 AM

I think I missed something - you should disable POST_VIDEO in the /etc/default/acpi-support file.

vince.fyre 08-03-2008 05:17 PM

i got all three steps finished, looked on google, like you advised, just to make sure everything was done properly. i rebooted, tried again, and no luck. same result...


All times are GMT -5. The time now is 02:49 PM.